Jump to:

558 Posts in 3589 Topics by 244 members

Hosting Requirements

SilverStripe Forums » Hosting Requirements » Trying to work with my old webhost

What you need to consider when choosing a hosting provider and plan.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 877 Views
  • dbc
    Avatar
    Community Member
    7 Posts

    Trying to work with my old webhost Link to this post

    I've been struggling to get SS working on my old webhost, but I'm just about ready to give up if I simply can't get all the needed requirements in place for SS to work correctly. Can I just clarify all the necessities for installing SS on IIS 6.0?

    - PHP 5.0++
    - MySQL 5.0++
    - IIS 5.x++
    - Windows Server (not sure which version)

    Is there something else that I am missing? Is the URL Rewrite mod something that is an absolute necessity? Despite having most of the following in place, I am still getting errors when attempting to install SS on my development site and it's getting very tiresome to have to go back and forth between my hosting provider because of some minor configuration issue.

    Short of changing webhosts, what else can I do?

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: Trying to work with my old webhost Link to this post

    There is a guide for setting up SilverStripe on IIS 6, but it assumes you have administrator access to the machine. Something a shared host probably doesn't have.

    URL rewrite needs to be done using a third-party tool called IIRF.

    Sean

    877 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.