Jump to:

4873 Posts in 7241 Topics by 1471 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Install Additional Modules

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1651 Views
  • 400guy
    Avatar
    Community Member
    4 Posts

    Install Additional Modules Link to this post

    I am brand new to Silverstripe. I am trying to install and use the Newsletter module. I am running on Windows Vista - 64bit.
    I loaded the Newsletter folder on my site. I did the /build?flush=1.
    I received no new icon to build newsletters. I moved the Newsletter folder to different locations under "mysite" and elsewhere under my "Silverstripe" folder structure.
    I eventually got the button to show, but when I clicked it, I received an error -

    [Warning] file_get_contents(C:\inetpub\wwwroot\silverstripe/cms/javascript/tinymce.template.js) [function.file-get-contents]: failed to open stream: No such file or directory
    GET /silverstripe/admin/newsletter/
    Line 472 in C:\inetpub\wwwroot\silverstripe\sapphire\core\Requirements.php

    How do I get started with the Newsletter module?

    Thanks, 400Guy.

  • Willr
    Avatar
    Forum Moderator
    5464 Posts

    Re: Install Additional Modules Link to this post

    You need to install the newsletter module in the root directory of your site - the one with sapphire, cms in it. Then after running /dev/build/ you should see things go green.

    One thing to note is make sure the folder is called 'newsletter' and not 'newsletter-13432' or something. Next thing to check is the database. After running dev/build look at your database structure (if you have phpmyadmin this works quite well) you need to check a 'Newsletter' table has been created.

    I received no new icon to build newsletters.

    Note that newsletters aren't page types. After you added the module it should add a tab up the top in the CMS.

    If you still have trouble post what versions you are using.

  • 400guy
    Avatar
    Community Member
    4 Posts

    Re: Install Additional Modules Link to this post

    I have put the Newsletter folder in the Sapphire directory; it is named "newsletter" - no extension on the name.
    I have run dev/build. Same results - I get the Newsletter tab at the top of the window, but it errors out when I click it:

    [Warning] file_get_contents(C:\inetpub\wwwroot\silverstripe/cms/javascript/tinymce.template.js) [function.file-get-contents]: failed to open stream: No such file or directory
    GET /silverstripe/admin/newsletter/
    Line 472 in C:\inetpub\wwwroot\silverstripe\sapphire\core\Requirements.php

    I also do NOT have the new "newsletter" table in my database.

    Silverstripe_Version file in root/silverstripe/sapphire indicates that I have Version 2.3.3. Will updating to 2.3.4 fix this?

  • Willr
    Avatar
    Forum Moderator
    5464 Posts

    Re: Install Additional Modules Link to this post

    You'll need to use an updated version of the module - http://open.silverstripe.org/ticket/4158

  • 400guy
    Avatar
    Community Member
    4 Posts

    Re: Install Additional Modules Link to this post

    I have removed then downloaded / re-installed Silverstripe (V2.3.4). I started completely from scratch.
    At this point, I was able to install the Newsletter module as described above.
    Now my only remaining issue is that I still can't SEND a newsletter. I have set up a simple mail list with just my e-mail on it for testing. No luck. I then tried sending to the Test e-mail (the first option) entering my email. Still no luck.

    Does this feature expect a local install of an e-mail client such as MS Outlook?
    I always run my mail on-line, so I do not have a local client set up.

    Other than that, I seem to be making progress! I am understanding it more every day as I experiment and test, and I look forward to creating and going live with a site in the next few weeks.

  • Willr
    Avatar
    Forum Moderator
    5464 Posts

    Re: Install Additional Modules Link to this post

    Can you send emails normally on your server? Sending emails requires nothing on the client side but you do have to configure your host to send email. If you try a simple mail script on the server does it work?

    mailme.php

    <?php
    echo mail('youremail@email.com', 'test');

    Upload that to the server (anywhere outside of SS) and see what that does.

  • 400guy
    Avatar
    Community Member
    4 Posts

    Re: Install Additional Modules Link to this post

    Unfortunately I do not have a mail server. I am running a test site on "localhost", and I do not have a mail server set up on this PC. I am still waiting on credentials for access to the site I will be working on. I believe that particular feature will have to wait until I have a server to load it on to test.

    For now, moving on to other features to try to understand - perhaps a BLOG feature?

    FYI - I find this forum to be VERY helpful. I received responses very promptly, and my problem is resolved, as far as I can tell!
    Now, if you can just get me to understand how all this stuff works, I'll be a very happy guy!

    400Guy

    1651 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.