Jump to:

4873 Posts in 7151 Topics by 1471 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Host changed DNS - now I can't upload assets

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1242 Views
  • Gina
    Avatar
    Community Member
    11 Posts

    Host changed DNS - now I can't upload assets Link to this post

    Hi - Not sure this is the correct place to ask this question. My site us up and working but my host changed their DNS and I have no earthly idea where I tell SS to use the new credentials to ftp files. I can't upload any assets and get an error when I try. It appears this is also affecting form submittals on the server. I did not originally install SS - a developer did this and he has abandoned me. If there is a file I can change to update this please tell me where to locate it. THANKS IN ADVANCE! :o(

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: Host changed DNS - now I can't upload assets Link to this post

    In Firefox, install the Firebug extension and then enable and open the console while you're trying to upload an asset - it's the little bug icon in the bottom right of Firefox once Firebug is installed. Copy and paste the error that shows into this thread and we'll see what the problem is.

  • Gina
    Avatar
    Community Member
    11 Posts

    Re: Host changed DNS - now I can't upload assets Link to this post

    Thanks so much. Installed Firebug, enabled Console, Enabled Profiler while trying to upload an asset. There are 32 calls listed here. Not sure what to paste or attach for you so please let me know if I am doing this correctly.

    Also fyi - SS is displaying this error in the window:
    Website Error
    There has been an error
    The website server has not been able to respond to your request.
    Contact an administrator: noreply [at] radimage [dot] com

    Thanks!

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: Host changed DNS - now I can't upload assets Link to this post

    Hi Gina,

    Could you add this to your mysite/_config.php file, and then see if you can get the error in Firebug again?

    Director::set_environment_type('dev');

    Once you've got the error, you can remove the line to set the site back into "live" mode.

    Cheers,
    Sean

    1242 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.