Jump to:

4948 Posts in 13638 Topics by 1488 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Problems installing 2.4.0-beta2

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 946 Views
  • Viv
    Avatar
    Community Member
    30 Posts

    Problems installing 2.4.0-beta2 Link to this post

    Trying to install a (fresh) installation of silverstripe-v2.4.0-beta2 for testing, on a server where I have had Silverstripe installations before. I am getting the following error right at the start:

    Fatal error: Call to undefined function apache_get_modules() in /var/www/vhosts/(mysite)/httpdocs/install.php on line 592

    This happens as soon as I enter www.(mysite).co.nz/ or www.(mysite).co.nz/install.php.

    I notice looking back in the older 2.3.x versions of Silverstripe (that I have installed on this server before), this same apache function is called, so it looks like nothing new. Does someone have help with this or is it something at my web-host end that is configured incorrectly now?

    Thanks for any help.

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: Problems installing 2.4.0-beta2 Link to this post

    This has been fixed here: http://open.silverstripe.org/changeset/101357/phpinstaller/branches/2.4/install.php

    It will appear in the RC1 release which should be fairly soon.

    Cheers,
    Sean

  • Viv
    Avatar
    Community Member
    30 Posts

    Re: Problems installing 2.4.0-beta2 Link to this post

    Thanks very much. Looking forward to trying out the changes in the 2.4 version.

  • patjnr
    Avatar
    Community Member
    101 Posts

    Re: Problems installing 2.4.0-beta2 Link to this post

    hi

    me im not getting any error messages but just a blank c=screen after it has redirected to install.php.
    beta 1 is working fine on the same server.

    ta

    PAt

  • Willr
    Avatar
    Forum Moderator
    5482 Posts

    Re: Problems installing 2.4.0-beta2 Link to this post

    PatJnr - getting anything in your php error logs?

    946 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.