Jump to:

4951 Posts in 14058 Topics by 1491 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » installation process seems to stall???

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3
Go to End
Author Topic: 2643 Views
  • borriej
    Avatar
    Community Member
    267 Posts

    Re: installation process seems to stall??? Link to this post

    ok i didnt told you all

    Also gave a few more files permision 777, but i didnt think it would make a difference. Maybe that is the clue (?)

    Files that i gave permission 777:
    - install.php
    - .htaccess
    - index.php
    - mysite (folder)
    - INSTALL
    - rewritetest.php

    Maybe try this?

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: installation process seems to stall??? Link to this post

    See if you can get display_errors set to "On" in your PHP.ini (you might need to ask your host this one).

    If it's set to Off you'll never know what the error is, which may be the reason why it just stalled and never provided any information why.

    You can also check the Apache errors.log and access.log files, which your host should also provide. These should be populated with any PHP errors that may have occurred during SilverStripe installation.

    Good luck!

    Sean

  • martin
    Avatar
    Community Member
    13 Posts

    Re: installation process seems to stall??? Link to this post

    Hmm... Ok, just tried setting permissions on those files to 777.

    Sadly no change.

    Will have to look into this PHP setting about "display errors"... perhaps there are errors, but I'm just not seeing them (how very unhelpful of the hosts to have it turned off).

    Cheers,
    m.

  • martin
    Avatar
    Community Member
    13 Posts

    Re: installation process seems to stall??? Link to this post

    Hi Sean,

    Thanks for the input.

    I have requested that the "display errors" be turned on. Host Support inform me that this has been done.

    I've tried the installation process once again and nothing seems to have changed.

    I am asking Hosting Support over the errors.log and access.log files.

    m.

  • martin
    Avatar
    Community Member
    13 Posts

    Re: installation process seems to stall??? Link to this post

    Hello again,

    Ok, I have been able to gain access to the v-server's error log (bearing in mind the the virtual server the domain is on houses 3 or 4 other domains too).

    I repeated my attempt to perform the install process at 4.22pm, just prior to downloading the log - so I could see what specific errors were thrown up at that time.

    The log for that time lists:

    [Wed Apr 28 16:22:50 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/

    This particular error is repeated several times during this week... I assume it's each time I'd tried the install. I'll post the whole list for this week (Mon, Tue and Wed) - don't know if they're all relevant.

    [Mon Apr 26 03:39:41 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Mon Apr 26 03:39:42 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Mon Apr 26 03:39:43 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Mon Apr 26 03:40:18 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Mon Apr 26 07:02:45 2010] [error] [client 217.197.152.228] File does not exist: /var/www/vhosts/default/htdocs/phpmyadmin
    [Mon Apr 26 07:02:45 2010] [error] [client 217.197.152.228] File does not exist: /var/www/vhosts/default/htdocs/pma
    [Mon Apr 26 07:02:45 2010] [error] [client 217.197.152.228] File does not exist: /var/www/vhosts/default/htdocs/admin
    [Mon Apr 26 07:02:46 2010] [error] [client 217.197.152.228] File does not exist: /var/www/vhosts/default/htdocs/dbadmin
    [Mon Apr 26 07:02:47 2010] [error] [client 217.197.152.228] File does not exist: /var/www/vhosts/default/htdocs/mysql
    [Mon Apr 26 07:02:47 2010] [error] [client 217.197.152.228] File does not exist: /var/www/vhosts/default/htdocs/php-my-admin
    [Mon Apr 26 07:02:47 2010] [error] [client 217.197.152.228] File does not exist: /var/www/vhosts/default/htdocs/myadmin
    [Mon Apr 26 07:02:48 2010] [error] [client 217.197.152.228] File does not exist: /var/www/vhosts/default/htdocs/PHPMYADMIN
    [Mon Apr 26 07:02:51 2010] [error] [client 217.197.152.228] File does not exist: /var/www/vhosts/default/htdocs/phpMyAdmin
    [Mon Apr 26 07:02:51 2010] [error] [client 217.197.152.228] File does not exist: /var/www/vhosts/default/htdocs/p
    [Mon Apr 26 07:02:52 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Mon Apr 26 13:08:20 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Mon Apr 26 13:19:53 2010] [error] [client 222.208.183.218] script '/var/www/vhosts/default/htdocs/prx2.php' not found or unable to stat
    [Mon Apr 26 13:29:10 2010] [error] [client 67.19.79.218] File does not exist: /var/www/vhosts/default/htdocs/robots.txt
    [Mon Apr 26 14:25:09 2010] [error] [client 124.232.152.116] script '/var/www/vhosts/default/htdocs/prx2.php' not found or unable to stat
    [Mon Apr 26 22:29:57 2010] [error] [client 88.80.10.1] File does not exist: /var/www/vhosts/default/htdocs/pp
    [Tue Apr 27 03:36:35 2010] [error] [client 222.208.183.218] script '/var/www/vhosts/default/htdocs/prx2.php' not found or unable to stat
    [Tue Apr 27 06:04:40 2010] [error] [client 222.208.183.218] script '/var/www/vhosts/default/htdocs/prx2.php' not found or unable to stat
    [Tue Apr 27 09:35:30 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Tue Apr 27 10:06:41 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Tue Apr 27 10:45:33 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Tue Apr 27 11:18:29 2010] [error] [client 81.28.196.116] File does not exist: /var/www/vhosts/default/httpsdocs/phpmyadmin
    [Tue Apr 27 11:18:29 2010] [error] [client 81.28.196.116] File does not exist: /var/www/vhosts/default/htdocs/phpmyadmin
    [Tue Apr 27 11:18:29 2010] [error] [client 81.28.196.116] File does not exist: /var/www/vhosts/default/httpsdocs/phpmyadmin
    [Tue Apr 27 11:18:29 2010] [error] [client 81.28.196.116] File does not exist: /var/www/vhosts/default/htdocs/phpmyadmin
    [Tue Apr 27 14:39:09 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Tue Apr 27 16:17:40 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Tue Apr 27 21:54:57 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Wed Apr 28 03:46:08 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Wed Apr 28 08:48:43 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Wed Apr 28 15:36:23 2010] [error] [client 124.232.152.116] script '/var/www/vhosts/default/htdocs/prx2.php' not found or unable to stat

    Does this help?

    Cheers,
    m.

  • martin
    Avatar
    Community Member
    13 Posts

    Re: installation process seems to stall??? Link to this post

    Hi Sean (and anyone else who might be reading this),

    Gentle thread nudge...

    I've supplied the error log info (above). Is there something *obvious* within that information which might explain why my installer's not installing?

    Thanks in advance.

    Martin.

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: installation process seems to stall??? Link to this post

    [Tue Apr 27 10:45:33 2010] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/

    This means AllowOverride All isn't set. You may want to ask your host to provide you with this, since it's required for nice URLs to work!

    Cheers,
    Sean

  • martin
    Avatar
    Community Member
    13 Posts

    Re: installation process seems to stall??? Link to this post

    Thanks Sean,

    I shall contact to the Hosting company over this and report back.

    Cheers,
    m.

    2643 Views
Page: 1 2 3
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.