Jump to:

4938 Posts in 16602 Topics by 1490 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Has anyone been able to install & use on a Zeus server?

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1387 Views
  • oldwrinkly
    Avatar
    Community Member
    34 Posts

    Has anyone been able to install & use on a Zeus server? Link to this post

    After weeks of getting my head round silverstripe and designing my site I finished it, but the last hurdle has stumped me.
    I have managed to install on a zeus server (namesco) using a rewrite script from another post on here and deleting the htaccess file but cannot use the cms at all, None of my pages show up, just the install opening pages and is also without a `save & publish` button.

    Unless anyone can help I seem to have wasted an awful lot of time and effort.

    The script I used.......

    # rewite script for zeus servers

    match URL into $ with ^/.*\.(gif|jpg|png|css|js).*$
    if not matched
    match URL into $ with ^/(.*)$
    if matched
    look for file at $1
    if not exists
    # Set the default page to be displayed if the URL is not a file or resource
    set URL = /sapphire/main.php?url=$1
    goto END
    endif
    endif
    endif

    Regards
    Mike

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: Has anyone been able to install & use on a Zeus server? Link to this post

    Try browsing to index.php/admin, e.g. http://mysite.com/index.php/admin. Does it work?

    Also, are you using SS 2.4.0?

    Note: We have not tested SS on Zeus. It's also not in the server requirements or suggested web hosts.

    That said, if we can figure it out then the more web servers SS works with the better.

    Sean

  • codem
    Avatar
    Community Member
    6 Posts

    Re: Has anyone been able to install & use on a Zeus server? Link to this post

    Hi

    I found this post while trying to get a SS install running on a 'Zeus' web server. The problem with the "match URL into $ with ^/.*\.(gif|jpg|png|css|js).*$" is that it isn't case insensitive and it filters out paths with certain extensions (e.g .flv, .swf etc) and paths without extensions (e.g the admin getItem ajax request - so the /admin just doesn't work).

    I blogged a solution here, partly taken from a Drupal solution, partly through debugging how the Base URL was set in the HTML head.

    http://www.codem.com.au/streams/2010/web-development/zeus-and-crazy-url-rewriting.html

    I'd avoid Zeus at all costs still.

    Hope it helps
    James

    1387 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.