Jump to:

4873 Posts in 7241 Topics by 1471 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » get stuck logging in to CMS

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1457 Views
  • quiet_islander
    Avatar
    Community Member
    17 Posts

    get stuck logging in to CMS Link to this post

    Hi, people:

    I don't know why but I get stuck on CMS logging in page on a clean SS2.4.0 install. Using firebug, I can see that I always get 13 javascript errors. See attachment.

    However, if I append "?isDev=1" to the url, everything works fine. Anyone can help me out?

    Thanks in advance.

    Attached Files
  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: get stuck logging in to CMS Link to this post

    Hi there,

    Please double check the assets directory has correct permissions. The problem could be that combined javascript files aren't being created, and so they don't get loaded properly. assets/_combinedfiles/ should have been created, and have 3 js files in there.

    If in dev mode, combined files are not used. This would explain why it works in dev mode.

    The alternative is to just disable this completely, addng this into mysite/_config.php

    Requirements::set_combined_files_enabled(false);

    Sean

  • quiet_islander
    Avatar
    Community Member
    17 Posts

    Re: get stuck logging in to CMS Link to this post

    Thanks a lot. This solved the problem.

    The _combinedfiles folder was created but had no write permission. It was an empty folder. The reason it could not be set with correct permission probably is that it was owned by the apache server, not the script. I then just add Requirements::set_combined_files_enabled(false); to the _config.php file and it works.

    I don't actually understand what the "combined files" thing is and why it is used in live mode by default but not in dev mode. Is there any documents explaining this bit on the SS official site? I'd like to learn something about it.

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: get stuck logging in to CMS Link to this post

    There's a bit of information here: http://doc.silverstripe.org/requirements

    1457 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.