Jump to:

4935 Posts in 16178 Topics by 1488 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » silverstripe MS- SQL installation problem

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3 4
Go to End
Author Topic: 4929 Views
  • dips_045
    Avatar
    Community Member
    20 Posts

    silverstripe MS- SQL installation problem Link to this post

    Hi,

    I successfully managed to create a working CMS on a linux server so thought I would try it for a windows server aswell but I am having problems.

    on install.php, there was an error message but I tried to enter in the details of the database anyway, which met the requirements without any problems. When I clicked on install I got the following error:

    Error Summary
    HTTP Error 500.0 - Internal Server Error
    C:\Program Files (x86)\PHP\php-cgi.exe - The FastCGI process exited unexpectedly

    Detailed Error Information
    Module   FastCgiModule
    Notification   ExecuteRequestHandler
    Handler   PHP_via_FastCGI
    Error Code   0xc0000005

    Can anyone please help?

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: silverstripe MS- SQL installation problem Link to this post

    I suggest setting up your Windows box like these instructions if at all possible: http://doc.silverstripe.org/installation-on-windows-server-manual-iis

    This also includes using the SQL Server Driver for PHP, provided by Microsoft, instead of the one that comes with PHP.

    If it's a shared Windows host, what are the server specifications you're installing SilverStripe onto?

    Sean

  • dips_045
    Avatar
    Community Member
    20 Posts

    Re: silverstripe MS- SQL installation problem Link to this post

    Hi Sean,

    Thanks for replying.... I'm half way through the guide...Taking a while but I'm getting there.

    I'm going to continue tomorrow and will let you know how I get on.

    Thanks again!

  • dips_045
    Avatar
    Community Member
    20 Posts

    Re: silverstripe MS- SQL installation problem Link to this post

    Hi,

    I had to put this project on hold for a while - but I'm back on it. I followed the instructions you sent but still had no luck. However I have noticed that this time round I had no errors on the install.php and met the requirements!

    But...I still got the same error message after I clicked install

    HTTP Error 500.0 - Internal Server Error
    C:\Program Files (x86)\PHP\php-cgi.exe - The FastCGI process exited unexpectedly
    Detailed Error Information
    Module   FastCgiModule
    Notification   ExecuteRequestHandler
    Handler   PHP_via_FastCGI
    Error Code   0xc0000005
    Requested URL   http://www.website.co.uk:80/silverstripe/install.php
    Physical Path   e:\inetpub\win422\website\silverstripe\install.php
    Logon Method   Anonymous
    Logon User   Anonymous

    I have also noticed that I don't have sp1 on Windows Vista - is this a problem?

    Any ideas how I can get silverstripe to work on a windows server?

    Many thanks for your help

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: silverstripe MS- SQL installation problem Link to this post

    You should be using Service Pack 2 if on Windows Vista. Please also check you are using the following components:

    * PHP 5.3.3 VC9 x86 Non Thread Safe (http://windows.php.net/download)
    * SQL Server driver for PHP 5.3 Non Thread Safe (http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=80e44913-24b4-4113-8807-caae6cf2ca05)

    The common cause of "FastCGI unexpectedly ended" errors is a misconfiguration of the server software.
    You may also want to make sure that the line "extension=php_mssql.dll" is commented out in php.ini. This driver should not be used.

    It might be a good idea to run Windows Update and patch everything available, this is generally a good idea anyway.

    Cheers,
    Sean

  • dips_045
    Avatar
    Community Member
    20 Posts

    Re: silverstripe MS- SQL installation problem Link to this post

    Thanks for replying - I have now installed SP2 and went through the following instructions again:
    http://doc.silverstripe.org/installation-on-windows-server-manual-iis

    I had installed PHP but when I tried to complete the following step - set up Handler Mappings in IIS to support PHP scripts, I get an error message 'The specified exceutable does not exist on the server'.

    I then removed PHP and installed it again making sure I selected IIS FastCGI and checked LDAP and Multi-Byte String. When I typed in “C:\Program Files (x86)\PHP\php-cgi.exe” in the Executable (optional) field, a messge came up asking if I want to create a FastCGI application for this executable - I clicked Ok and get the error message mentioned above.
    I tried to find php-cgi.exe on my machine and couldn't find it.

    Any help/advice?

    Many thanks

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: silverstripe MS- SQL installation problem Link to this post

    Did you choose "IIS" as the web server during install of PHP? It will ask whether you're using Apache or IIS.

    Try uninstalling and doing it again. I think it tries to automatically set up the handler mappings for IIS during PHP install as well.

    Cheers,
    Sean

  • dips_045
    Avatar
    Community Member
    20 Posts

    Re: silverstripe MS- SQL installation problem Link to this post

    Hi - I uninstalled it again and installed it but still got the same result.

    There wasn't an option for selecting IIS. I downloaded this version of PHP:
    VC9 x86 Non Thread Safe (2010-Jul-21 20:38:25)

    Any ideas on what else I can try?

    4929 Views
Page: 1 2 3 4
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.