Jump to:

4938 Posts in 16827 Topics by 1490 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Installation Openhost

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1205 Views
  • Monty
    Avatar
    Community Member
    19 Posts

    Installation Openhost Link to this post

    Hi I am installing SilverStripe on one of the Openhost Linux Silver plans (NZ). I also have a VPS and I had no issues installing sites on that.

    I am getting this error:

    . "\$baseClass not set", E_USER_ERROR);

    I have followed this advice from the forums...

    Turn ON mod_rewrite
    Turn OFF magic quotes off
    Turn OFF PHP Safe Mode
    Turn OFF mbstring.function_overload

    Any help appreciated. Thanks.
    David.

  • Monty
    Avatar
    Community Member
    19 Posts

    Re: Installation Openhost Link to this post

    Ok... so the problem here was Openhost had not made the changes.

    So in summary these are the requirements for Openhost:

    Turn ON mod_rewrite
    Turn OFF magic quotes off
    Turn OFF PHP Safe Mode
    Turn OFF mbstring.function_overload

    I also found I needed to add the .htaccess file manually and described in a previous Forum post. Hope this helps.

    Cheers,
    David.

    1205 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.