Jump to:

4952 Posts in 14381 Topics by 1491 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » SOOOOOO SLOW

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 2317 Views
  • Briohny
    Avatar
    Community Member
    199 Posts

    SOOOOOO SLOW Link to this post

    I'm guessing my problem is again with GoDaddy. In the mornings (Ireland - GMT) my site www.surfworld.ie loads super fast (2-3 seconds). By the end of the day it's loading at 32 seconds per page. It's driving me and my customers insane. I don't know if it's coincidental that it's working mornings and not evenings or if this actually has anything to do with it. I've contacted GoDaddy but as usual I'm still awaiting their response. Can anyone recommend a solution? Is this a memory problem? Configuration problem? I thought my previous Fast CGI error may have been the issue, but turns out it's not. Any ideas?

  • swaiba
    Avatar
    Forum Moderator
    1785 Posts

    Re: SOOOOOO SLOW Link to this post

  • Double-A-Ron
    Avatar
    Community Member
    604 Posts

    Re: SOOOOOO SLOW Link to this post

    What version Briohny?

  • Briohny
    Avatar
    Community Member
    199 Posts

    Re: SOOOOOO SLOW Link to this post

    Hey Aron,

    It's 2.3.1

  • Aram
    Avatar
    Community Member
    598 Posts

    Re: SOOOOOO SLOW Link to this post

    Make sure your assets/ folder has 777 permissions, I know that has caused speed issues before.

    Aram

    www.SSbits.com - Your one stop SilverStripe learning resource.

  • Double-A-Ron
    Avatar
    Community Member
    604 Posts

    Re: SOOOOOO SLOW Link to this post

    Briohny does this seem to be sporadic? And is that Flash animation half-way down quite new?

    I just loaded your site 5 times and the load time (to completion, not to a usable website page) ranged from 34 seconds to 4 seconds.

    I had firebug open all 5 times and noticed a couple of things:

    1. SurfworldFlash.swf took 18-32 seconds to fully load un-cached. It is a whopping 1.3MB
    2. banner.jpg took 17 seconds to fully load at it's worst. It is 370KB which is kinda large for an image, but not to the point that it should take 17 seconds to load. I think that the flash animation is contributing to this delay however.

    Un-cached, your home page is almost 2MB largely due to these two guys. That's a very large page for first time visitors to load. After the first load (and the files above are in cached), I get an average load time of 4s. If I clear my cache, I get 30-odd seconds again.

    Just as a temporary test - try removing that flash animation and see what happens.

    Aaron

  • Briohny
    Avatar
    Community Member
    199 Posts

    Re: SOOOOOO SLOW Link to this post

    Great, thanks guys. Thanks Aron... I didn't realise the flash or image was that big! Yikes! That surely would be contributing. I'm going to work on that now and see.

  • Briohny
    Avatar
    Community Member
    199 Posts

    Re: SOOOOOO SLOW Link to this post

    Yeah Aaron, very sporadic. But I've managed to get my site moved to a different GoDaddy server. It's now sitting on a GoDaddy 4GH server. It has made a world of difference. In addition, I optimised my flash file to around 600kb. The site seems to be working very well tonight. Aaron, would you mind giving it another whirl at your end? Thanks so much for your time and help on this. Really, really appreciate it.

    2317 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.