Jump to:

4873 Posts in 7242 Topics by 1471 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » /dev/build not affecting database

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 968 Views
  • Lazarus404
    Avatar
    Community Member
    71 Posts

    /dev/build not affecting database Link to this post

    Hey guys,

    I have a SilverStripe install which is up and running and works great. I've ported the database across and all is well. My problem, however, is with /dev/build. If I create any updates for the site and run /dev/build?flush=1, I get a list of changes to the site as expected in green or blue, but the updates aren't actually happening. I can rerun /dev/build?flush=1 as many times as I like and see the same updates every time, but no changes to the database are being made.

    Does anyone know what might be the cause? It doesn't appear to be the database user.

    Thanks,
    Lee

  • Willr
    Avatar
    Forum Moderator
    5464 Posts

    Re: /dev/build not affecting database Link to this post

    Do you see "Database built successfully" at the bottom of the page?

  • Lazarus404
    Avatar
    Community Member
    71 Posts

    Re: /dev/build not affecting database Link to this post

    Yes. It all looks normal, but no structural changes are actually made. SilverStripe has no issue with adding, updating or deleting data, though.

    Lee

  • TDNP
    Avatar
    Community Member
    19 Posts

    Re: /dev/build not affecting database Link to this post

    Was there ever a solution to this problem? I have recently made changes to one of my page types, uploaded the file to the server and ran dev/build?flush=1 and dev/build?flush=all with no success. The build completes successfully but doesn't update the database. Then if I attempt to access one of the pages that would be affected in the admin area, I get a grey screen that simply says "There has been an error."

    SilverStripe 2.4.5 I think.

    968 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.