Jump to:

4952 Posts in 14312 Topics by 1491 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Theme woes

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 398 Views
  • Bikerboy
    Avatar
    Community Member
    3 Posts

    Theme woes Link to this post

    Silverstripe would appear to be a great advance on a couple of other CMS's I have tried but I have already hit a couple of snags.

    The first is that I the CMS link at the bottom of the page does not work and I can't seem to get back to page that allows me to set the theme. I have uploaded the 'Highway' theme and tried to install it but all I have now for my pains is this -

    http://ogradydrivertraining.com/stripe/limerick-courses/

    I did clear the cache and alter the code as directed, or made the attempt anyway.

    If I can get past this little hurdle then I'm sure I can get moving again but at the moment I'm facing something of a blank wall.

  • Willr
    Avatar
    Forum Moderator
    5489 Posts

    Re: Theme woes Link to this post

    As it says 'Generated with the default ContentController.ss template' which means it cannot find your theme. Make sure you spelt your theme name correct, the same as the name of the folder in your themes folder, same case, same everything. Then make sure themes/yourthemename/templates/Page.ss exists and is readable by your webserver.

  • Bikerboy
    Avatar
    Community Member
    3 Posts

    Re: Theme woes Link to this post

    Hi Will

    Thanks for the response, I started right from the beginning again by reinstalling Silverstripe totally and working through the stages. Not quite sure what the sticking point was before but there are a couple of items which new/future users might find it useful to note.

    1. The Highway theme unzips as a directory called 'highway' in which there is a sub directory also called 'highway'. It's this sub directory which needs loading into the themes folder on the server.

    2. When flushing the cache you need to append '?flush=1' to the url and directory path. ie 'www.domainname/stripe?flush=1' not just the URL alone as instructed in the installation notes.

    398 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.