4873 Posts in 7242 Topics by 1471 members
|Go to End|
23 August 2012 at 8:55pm Last edited: 24 August 2012 2:07am
Disaster struct today when I found out to my horror that SS 3 requires PHP 5.3.2 and my host provider (who shall remain nameless) only supports 5.2.17 on their basic packages (because of some backwards compatibility issue with other software). humph...
This is a nightmare for me because I'm very dependant on SilverStripe and I can't easily switch hosts (not in the short run anyway).
My only option, short term is to install a previous version of Silverstripe that uses PHP 5.2 - looking in the repo I can see that a lot of 2.4 security patches seem to require php 5.32 - now this seems rather odd that a minor release of a software package would require a major upgrade of PHP!
If I go direct to the 2.4 branch I can see that only requires 5.2 but I have no idea if this incorporates the security patches or not.
So my question is, what's the latest, most stable version I can install of silverstripe with php 5.2?
EDIT: answer: 2.4 only - (works with latest security patch for 2.4).
23 August 2012 at 11:32pm
By the way, back-porting something coded in version 3 to version 2.4 is no picknick either. I managed it but I had to change both my theme and the 'mysite' code in several places. Not very nice.
|Go to Top|