Jump to:

4938 Posts in 16827 Topics by 1490 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » SilverStripe 2.4 download

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 2291 Views
  • Stef87
    Avatar
    Community Member
    66 Posts

    SilverStripe 2.4 download Link to this post

    Hi

    Does anyone know where I can get a download of 2.4? I tried downloading it from here but I keep getting an error that it is missing template files. I can't download the 2.4.7 version on the SilverStripe downloads page as I'm using a Mac. This error only shows up when I put it in dev mode and doesn't seem to effect the performance otherwise but I figured it must be causing an issue somewhere.

    I'd appreciate any help.

    Update I reinstalled SilverStripe, did absolutely nothing else, and I get the same error.

  • kinglozzer
    Avatar
    Community Member
    140 Posts
  • Stef87
    Avatar
    Community Member
    66 Posts

    Re: SilverStripe 2.4 download Link to this post

    Nope. Same issue with that download. I am really confused about this. I have done everything the installation instructions have told me and haven't done a thing to the install, except put

    Director::set_environment_type("dev");

    in the _config.php file, and it's got this error.

    Update Through a process of trial and error it turns out that the problem lay with the latest version of PHP (5.4.3). SilverStripe 2.4.7 has core methods which have been deprecated in the latest version of PHP. Problem solved.

  • MooreDynasty
    Avatar
    Community Member
    3 Posts

    Re: SilverStripe 2.4 download Link to this post

    stef, what was your resolution? Roll back to a previous version of PHP??

  • Stef87
    Avatar
    Community Member
    66 Posts

    Re: SilverStripe 2.4 download Link to this post

    Hi MooreDynasty

    As far as I remember this turned out to be a conflict with PHP. Version 2.4.7 of SilverStripe isn't compatible with the latest PHP release (or the one before I think) so I had to go back to using PHP 5.2.17 instead.

    Hope that helps.

    Stef

    2291 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.