Jump to:

4935 Posts in 16178 Topics by 1488 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Troubles with install

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 538 Views
  • USvER
    Avatar
    Community Member
    6 Posts

    Troubles with install Link to this post

    Hi,

    I have troubles with installing SS.
    First of all i have tryed to install SS on a Denwer WAMP. And Apache just crush after i navigate to main page.
    Then i tryed to install it on a XAMPP. And it just throw me an error even on the install script. I guess becouse of php 5.1.6
    Now i'm tring to install it on Winginx. Wich is sort of WAMP but based on NGINX. And i having troubles with fancy url becose NGINX dont have mod_rewrite. It has own module for url rewrite...

    So my question is: please explain in a simple language what request shuld be rewrited to make SS work.
    And please kindly explain why installer requires fancy urls???? Is this something that shuld be search engine optimized :LOL:

    Or may be you know how to turn this FURL off???

  • Willr
    Avatar
    Forum Moderator
    5497 Posts

    Re: Troubles with install Link to this post

    PHP 5.1.6 isn't supported. Check http://doc.silverstripe.org/framework/en/installation/nginx for an example of an nginx configuration.

  • USvER
    Avatar
    Community Member
    6 Posts

    Re: Troubles with install Link to this post

    This is what i get after installation of SS on Winginx using that configuration.
    Install script say OK then redirect to the flush page wich was NGINX default 404.

    Attached Files
  • USvER
    Avatar
    Community Member
    6 Posts

    Re: Troubles with install Link to this post

    I got SS working on my LAMP and on my Windows machine with Apache + PHP + MySQL manualy installed to latest versions.
    Still issue remains... no WAMP culd handle SS... And i culd not get SS working on Nginx with configuration posted on the official tutorial page. I guess it's outdated!

    538 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.