Jump to:

4945 Posts in 17872 Topics by 1494 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » [ERROR] SS3 installation error invalid opcode

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1073 Views
  • Sphere
    Avatar
    Community Member
    44 Posts

    [ERROR] SS3 installation error invalid opcode Link to this post

    I keep getting this error:
    PHP Fatal error: Invalid opcode 153/1/8. in framework/i18n/i18n.php on line 1952
    The piece of code that's breaking:

          uksort(
             $modules,
             function($a, $b) use(&$prios) {
                $prioA = (isset($prios[$a])) ? $prios[$a] : 50;
                $prioB = (isset($prios[$b])) ? $prios[$b] : 50;
                return ($prioA > $prioB);
             }
          );


    When doing a dev/build.

    On the live/production side, the same error occurs, but in datalist:
    PHP Fatal error: Invalid opcode 153/1/8. in framework/model/DataList.php on line 205
    Which is this code:

       public function where($filter) {
          return $this->alterDataQuery_30(function($query) use ($filter){
             $query->where($filter);
          });
       }

    The PHP-version on the server is 5.3.17

    Any clue?

  • tv
    Avatar
    Community Member
    44 Posts

    Re: [ERROR] SS3 installation error invalid opcode Link to this post

    Hi Sphere,

    I hit you up on Twitter about this, too, but wondering if you were able to find the cause of this error? I'm receiving the exact same error when I've moved my install to production.

  • Sphere
    Avatar
    Community Member
    44 Posts

    Re: [ERROR] SS3 installation error invalid opcode Link to this post

    The error here is due to a PHP-cacher named eAccelerator. eAccelerator doesn't allow for anonymous functions, which causes this error. Only solution is either disable eAccelerator, or find a host that uses APC (or no PHP-cacher)

  • tv
    Avatar
    Community Member
    44 Posts

    Re: [ERROR] SS3 installation error invalid opcode Link to this post

    Thanks so much for the quick reply and info. Gonna hit up our hosting provider and find out.

  • tv
    Avatar
    Community Member
    44 Posts

    Re: [ERROR] SS3 installation error invalid opcode Link to this post

    For anybody else who has this issue, Sphere was correct - eAccelerator was the issue. Disabled it and was able to move forward.

    1073 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.