Jump to:

4938 Posts in 16602 Topics by 1490 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » 500 Internal Server Error on install

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 760 Views
  • mickk
    Avatar
    Community Member
    5 Posts

    500 Internal Server Error on install Link to this post

    Hi there i am having trouble installing this on my server. Any advise would be appreciated.

    Every page i go to all i get is a internal server error.

    Any ideas?

    Thanks
    Mike

  • Willr
    Avatar
    Forum Moderator
    5502 Posts

    Re: 500 Internal Server Error on install Link to this post

    Check your php / server error logs for the error details.

  • mickk
    Avatar
    Community Member
    5 Posts

    Re: 500 Internal Server Error on install Link to this post

    Software: Microsoft Internet Information Services 7.5
    #Version: 1.0
    #Date: 2013-05-28 14:44:48
    #Fields: date time s-sitename s-computername s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs-version cs(User-Agent) cs(Cookie) cs(Referer) cs-host sc-status sc-substatus sc-win32-status sc-bytes cs-bytes time-taken
    2013-05-28 14:44:48 W3SVC13 WIN-L8U5P1S0OEE 76.74.186.212 GET / - 80 - 64.141.99.61 HTTP/1.1 Mozilla/5.0+(Macintosh;+Intel+Mac+OS+X+10.8;+rv:22.0)+Gecko/20100101+Firefox/22.0 - - byblosbakery.com 500 0 1610 1577 299 12515
    2013-05-28 14:45:09 W3SVC13 WIN-L8U5P1S0OEE 76.74.186.212 GET / - 80 - 64.141.99.61 HTTP/1.1 Mozilla/5.0+(Macintosh;+Intel+Mac+OS+X+10.8;+rv:22.0)+Gecko/20100101+Firefox/22.0 - - byblosbakery.com 500 0 1610 1577 325 31
    2013-05-28 14:45:09 W3SVC13 WIN-L8U5P1S0OEE 76.74.186.212 GET / - 80 - 64.141.99.61 HTTP/1.1 Mozilla/5.0+(Macintosh;+Intel+Mac+OS+X+10.8;+rv:22.0)+Gecko/20100101+Firefox/22.0 - - byblosbakery.com 500 0 1610 1577 325 31
    2013-05-28 14:45:11 W3SVC13 WIN-L8U5P1S0OEE 76.74.186.212 GET / - 80 - 64.141.99.61 HTTP/1.1 Mozilla/5.0+(Macintosh;+Intel+Mac+OS+X+10.8;+rv:22.0)+Gecko/20100101+Firefox/22.0 - - byblosbakery.com 500 0 1610 1577 325 31

  • Willr
    Avatar
    Forum Moderator
    5502 Posts

    Re: 500 Internal Server Error on install Link to this post

    That doesn't look useful. Probably wrong logs. Look for php_errors or similar references to PHP

  • mickk
    Avatar
    Community Member
    5 Posts

    Re: 500 Internal Server Error on install Link to this post

    Finally got the specific error. Any ideas?

    HTTP Error 500.0 - Internal Server Error
    Hidden Segments may not contain a '/' or '\' character

  • saimis
    Avatar
    Community Member
    1 Post

    Re: 500 Internal Server Error on install Link to this post

    If you're using IIS, go to the Server manager, select the site that shows this error, then in center panel select "Request Filtering", inside you'll find tab named "Hidden Segments", there is already added segment "silverstripe-cache/" remove it and site will start to work. Don't know yet if you need to add it without slash or leave as is...

    760 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.