Jump to:

4956 Posts in 14389 Topics by 1492 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Installing using Composer - error 267

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1337 Views
  • Christy
    Avatar
    Community Member
    57 Posts

    Installing using Composer - error 267 Link to this post

    I am endeavouring to install Silverstripe using Composer as recommended. Error after error installing Composer and now problems with SS. I have moved on to 3.1.0 beta3 as per a forum message.

    Can someone please enlighten me on what is causing this error message.

    [ErrorException]
    proc_open(): CreateProcess failed, error code - 267

    C:\Documents and Settings\Administrator>composer create-project silverstripe/ins
    taller ./wamp/www/ctla_stripe 3.1.x-dev --no-dev
    Installing silverstripe/installer (3.1.x-dev 0b59ef4026ace58c04894fcbd0a14f0026c
    68c11)
    - Installing silverstripe/installer (3.1.x-dev 0b59ef4)
    Cloning 0b59ef4026ace58c04894fcbd0a14f0026c68c11

    Created project in ./wamp/www/ctla_stripe
    Loading composer repositories with package information
    Installing dependencies
    - Installing composer/installers (dev-master 34bd8e8)
    Cloning 34bd8e879adc82fac26eb2c7551a03e04f9b7e3a

    - Installing silverstripe/framework (3.1.x-dev 541436f)
    Cloning 541436feb0fa38bb42490e19f228392f08cb8398

    - Installing silverstripe/cms (3.1.x-dev f937b95)
    Cloning f937b95eaf2b74ee75b46ad56a44e9126a927690

    - Installing silverstripe-themes/simple (dev-master fa34633)
    Cloning fa346339a5237460ad94c6efea66c54b0585501f
    [ErrorException]
    proc_open(): CreateProcess failed, error code - 267

    create-project [-s|--stability="..."] [--prefer-source] [--prefer-dist] [--repos
    itory-url="..."] [--dev] [--no-dev] [--no-custom-installers] [--no-scripts] [--n
    o-progress] [--keep-vcs] [package] [directory] [version]

    C:\Documents and Settings\Administrator>

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: Installing using Composer - error 267 Link to this post

    Hmm, seems like it relates to an error about an invalid directory name. http://codophony.blogspot.co.nz/2013/04/composer-in-cygwin-createprocess-failed.html

    Perhaps try another directory. Usually on Windows for WAMP you'd install into C:\wamp\www\ or somewhere similar, e.g.

    composer create-project silverstripe/installer C:\wamp\www\myss3proj 3.1.x-dev

    Sean

  • Christy
    Avatar
    Community Member
    57 Posts

    Re: Installing using Composer - error 267 Link to this post

    Thanks for your prompt reply, Sean.

    I tried putting in the full path as you suggested and then tried again with C:\wamp\www\ in the path. Both gave the same error.

    I am reduced to wondering how important using Composer is if you don't plan to alter core files!

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: Installing using Composer - error 267 Link to this post

    From a look at the output, it seems like Composer was able to download the files correctly, but the error occurred after it had finished that, presumably one of the post install scripts.

    It might be related to a change to the installer here for 3.1: https://github.com/silverstripe/silverstripe-installer/commit/26147bb962ba8246e3bb0dc61624bcc45019d996#composer.json

    If you access the site in your browser where you installed it does it bring up the installer? e.g. http://localhost/ctla_stripe

    Sean

  • Christy
    Avatar
    Community Member
    57 Posts

    Re: Installing using Composer - error 267 Link to this post

    Yes - it brings up the CMS/Framework Installation window. I will carry on and see if the installation causes any problems.

    (Back slash or forward slash in the path gave the same result.)

    Thank you very much - it has taken some to get this far with Composer!

    Regards
    Christy

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: Installing using Composer - error 267 Link to this post

    Hi Christy,

    Good to hear that worked.

    The post scripts ended up being reverted, so the create-project command should work from now on:
    https://github.com/silverstripe/silverstripe-installer/commit/d4e574883565c36b095620ebc01cd347ac50195d

    Sean

    1337 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.