Jump to:

4873 Posts in 7242 Topics by 1471 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Problems when installing RC2

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 2501 Views
  • mcrosby
    Avatar
    Community Member
    4 Posts

    Problems when installing RC2 Link to this post

    Fatal error: Call to undefined function token_get_all() in /usr/home/sites/www.speedygeek.co.uk/domains/markcrosby.co.uk/web/sapphire/core/ManifestBuilder.php on line 391

    Hi Folks!

    I'm getting the above error when installing (or upgrading to) v2.3.0-rc2 using build?flush=1. I'm running FreeBSD 6.3.

    I couldn't find anyone else on the forums with the same problem, so assume it must be something I'm doing wrong, although I've followed the instructions completely, and have been installing scripts for years.

    Any help would be appreciated, as I'm completely stuck!

  • davegp
    Avatar
    Community Member
    6 Posts

    Re: Problems when installing RC2 Link to this post

    Hi mcrosby!
    I had this issue too while trying to install SS on freebsd. It seems you might be missing a php5 module:
    /usr/ports/devel/php5-tokenizer/
    I installed this and the error went away.
    However, I still haven't managed to get a successful install of SS.
    Maybe we can keep track of each other to find a common solution.
    Best,
    davegp

  • mcrosby
    Avatar
    Community Member
    4 Posts

    Re: Problems when installing RC2 Link to this post

    Yes, sounds like a good idea!

    The current version of SS installs fine, and I can get the release candidate installed perfectly on wampserver locally.

    I'll get my host to install this module today, and report back.

  • davegp
    Avatar
    Community Member
    6 Posts

    Re: Problems when installing RC2 Link to this post

    Hi mcrosby,

    Just a note (for posterity and other souls in despair) that I did manage to get SS running on my freebsd server.

    An important note to your host with respect to changes in Apache configuration:
    If your IP is a virtual host, make sure changes such as Allow Override All appear in extras/httpd-vhosts.conf and not in the overarching httpd.conf - this screwed things up for me until I realized what I was doing.
    You can see where I mention this in another post on this forum
    http://silverstripe.org/installing-silverstripe/show/252377

    Best of luck,

    davegp

  • mcrosby
    Avatar
    Community Member
    4 Posts

    Re: Problems when installing RC2 Link to this post

    Thanks for the info Dave.

    I did get this working by getting my host to install php5-tokenizer. Since then, I've had no problems (so far!).

    2501 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.