Jump to:

4938 Posts in 16484 Topics by 1490 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » 404 When Accessing Via Subdomain

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1136 Views
  • jfusco
    Avatar
    Community Member
    52 Posts

    404 When Accessing Via Subdomain Link to this post

    I've been working all week accessing the site directly via http://www.unclebubby.com/wavs and that method is still working. I created a subdomain, http://wavs.unclebubby.com to point to the /wavs folder and it's not working. It appears the DNS settings have updated and the subdomain is directing to the correct folder but something isn't responding correctly.

    what I get is "The requested URL /wavs/sapphire/main.php was not found on this server." The files are obviously there or direct entry wouldn't work. I have emailed the support group for my hosting service, GoDaddy, but thought I would ask here as well. Is there some file (i.e. .htaccess) that I need to tweak to get it to work?

    Thanks,
    Joe

    Update: I tried editing the .htaccess file. I commented out the RewriteBase /wavs line thinking that maybe it thought it was looking for domain/wavs/wavs/sapphire/main.php but that didn't help. There's another line that contains the folder name but I don't know what that does so I don't want to mess with it unless someone knows that will fix it and what to change it to.

  • jfusco
    Avatar
    Community Member
    52 Posts

    Re: 404 When Accessing Via Subdomain Link to this post

    I located this thread:
    http://www.silverstripe.org/archive/show/159630

    "In order for SilverStripe to run correctly with subdomains, youll need to make sure that all the domains point to the same wwwroot - that is, both [mydomain.com] AND should have their wwwroot set to where you installed SilverStripe."

    I don't understand what that means and I don't know what I would have to change/update to make that happen. I have 4 different sites running through this domain. A portal of sorts, two photo galleries, and SilverStripe. They all run off of the same root directory. If I do what it says to make wavs.unclebubby.com work, will that break access to any of my other sites?

  • SalvaStripe
    Avatar
    Community Member
    89 Posts

    Re: 404 When Accessing Via Subdomain Link to this post

    i post in your other thread.. check this out:

    http://silverstripe.org/general-questions/show/253504

    1136 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.