Jump to:

4952 Posts in 14256 Topics by 1491 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Getting mod_rewrite to work correctly

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 638 Views
  • Attunga
    Avatar
    Community Member
    2 Posts

    Getting mod_rewrite to work correctly Link to this post

    I am playing around with getting SilverStripe installed on a local Ubuntu 14.04 installation.

    During the initial installation page it asked me to enable mod_rewrite and I did this to the point it detected it as working, then during the installation itself it was detecting that mod_rewrite was not working.

    I then did some reading and put the following into my apache configuration

    (/etc/apache2/sites-enabled/000-default.conf)

    <Directory /var/www/html>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>

    This has sort of left things in a half working state. The installation completes and if I force it to work with the url rewriting it kind of works but then reverts back with other links. It seems that if I manually type in the url for the about or contact page, then all links works correctly but if I try to go back to home it wants to start using the /index.php/[pagename] style of link.

    Does the above look ok? Any other ideas from anyone?

  • Attunga
    Avatar
    Community Member
    2 Posts

    Re: Getting mod_rewrite to work correctly Link to this post

    oh well .. I am almost giving up on SilverStripe but I do suspect that the issue has something to do with the way SilverStripe is working in with the latest Ubuntu LTS.

    I have followed this page: http://www.dev-metal.com/enable-mod_rewrite-ubuntu-14-04-lts/ And still get the same issue but dropping back to the previous LTS I have no problems, SilverStripe works as expected.

    Everything work very well on another CMS with the latest LTS, I think I am just going to run with that one, it has a far bigger community and range of add-on's and themes available in an easy to search format anyway. SilverStripe would do well with something like that.

    Might come back one day and have another look at SilverStripe if it fixes it's issues and has more of a community. I do like the idea of the framework being integrated and available for integrated applications, that is great feature.

  • camfindlay
    Avatar
    Forum Moderator
    146 Posts

    Re: Getting mod_rewrite to work correctly Link to this post

    Hi there,

    This may be related to the version of apache being run on the latest LTS of Ubuntu. The apache httpd.conf directive have slightly changed between version 2.2 and 2.4 of Apache.

    See https://groups.google.com/forum/#!topic/silverstripe-dev/-xH6yZfC5Tc explaining the issue and instructions to fix.

    638 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.