Jump to:

4951 Posts in 14058 Topics by 1491 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » PHP 5 is required

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3 4
Go to End
Author Topic: 6768 Views
  • JZM
    Avatar
    Community Member
    34 Posts

    Re: PHP 5 is required Link to this post

    I removed

    // Note: you should use <% require %> tags inside your
    templates instead of putting Requirements calls here. However
    // these are included so that our older themes still
    work

    Should I ask the host to turn it off

  • Sigurd
    Avatar
    Forum Moderator
    628 Posts

    Re: PHP 5 is required Link to this post

    Does your SilverStripe install work now?

    We're interested so we can 'fix' SilverStripe for those with the setting on.

  • JZM
    Avatar
    Community Member
    34 Posts

    Re: PHP 5 is required Link to this post

    Morning Sigurd

    No its still not installing - i tried it on my web server and it comes up with PHP5 required and the $end error but still installs - weird

  • Sigurd
    Avatar
    Forum Moderator
    628 Posts

    Re: PHP 5 is required Link to this post

    When you say "still installs", what state is the installation left in? You make it sound like it "tries to install but fails to do so?"
    Please be more specific so we can help:)

  • JZM
    Avatar
    Community Member
    34 Posts

    Re: PHP 5 is required Link to this post

    Sorry Sigurd been at uni,

    It installs on my server but during the installation it has

    Warning: unlink(mysite/_config.php) [function.unlink]: Permission denied in /home/jzmcon/public_html/Silver1/install.php on line 709

    I have chmoded it to 777

  • hempster
    Avatar
    Community Member
    4 Posts

    Re: PHP 5 is required Link to this post

    hey there!

    i´m getting the same error trying to install silverstripe 2.3.1
    hiere is the php info:
    http://web0.xfuture-server.de/info.php

    a small part of the errormessage is attached below.

    is there any workaround for this error?

    cheers!
    hempster

    ------------------------------------
    Warning: unlink(mysite/_config.php) [function.unlink]: Permission denied in /var/www/user/html/install.php on line 705
    # Creating 'mysite/_config.php'...
    # Creating /var/www/user/html/mysite/_config.php
    # Creating '.htaccess' file...
    # Creating /var/www/user/html/.htaccess

    Warning: fopen(/var/www/user/html/silverstripe-cache/manifestClassParse-_var_www_user_html_cms_code_AssetAdmin.php) [function.fopen]: failed to open stream: Permission denied in /var/www/user/html/sapphire/core/ManifestBuilder.php on line 398

    Warning: fopen(/var/www/user/html/silverstripe-cache/manifestClassParse-_var_www_user_html_cms_code_AssetTableField.php) [function.fopen]: failed to open stream: Permission denied in /var/www/user/html/sapphire/core/ManifestBuilder.php on line 398
    ....
    ...
    ..
    .

  • JZM
    Avatar
    Community Member
    34 Posts

    Re: PHP 5 is required Link to this post

    Hempster,

    Have you chmoded the files

  • hempster
    Avatar
    Community Member
    4 Posts

    Re: PHP 5 is required Link to this post

    hey jzm, thx for helping

    yes - all red marked files during the test-setup have been set to 777.
    i´ll make a fresh installation today and post some screenshots!

    6768 Views
Page: 1 2 3 4
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.