Jump to:

4873 Posts in 7241 Topics by 1471 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Warnings after Installation on the WebServer

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 3254 Views
  • anthias
    Avatar
    Community Member
    14 Posts

    Warnings after Installation on the WebServer Link to this post

    Hello. I am having problems with the installation on my web server.
    After the CMS Installation Page and after Re-checking requirements (which were all ok) - I recieved the following window (also see the attached file):

    "I am now running through the installation steps (this should take about 30 seconds)

    If you receive a fatal error, refresh this page to continue the installation

    Warning: unlink(mysite/_config.php) [function.unlink]: Permission denied in /www/htdocs/w00abc52/install.php on line 709
    * Creating 'mysite/_config.php'...
    * Creating /www/htdocs/w00abc52/mysite/_config.php
    * Creating '.htaccess' file...
    * Creating /www/htdocs/w00abc52/.htaccess

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(../../_ss_environment.php) is not within the allowed path(s): (/www/htdocs/w00abc52/:/tmp:/usr/bin:/www/htdocs/w00abc52:/bin:/usr/local/bin:/usr/share/php) in /www/htdocs/w00abc52/sapphire/core/Core.php on line 31

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(../../../_ss_environment.php) is not within the allowed path(s): (/www/htdocs/w00abc52/:/tmp:/usr/bin:/www/htdocs/w00abc52:/bin:/usr/local/bin:/usr/share/php) in /www/htdocs/w00abc52/sapphire/core/Core.php on line 31
    * Building database schema...
    * Checking that friendly URLs work...
    * Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
    o mod_rewrite is enabled
    o AllowOverride All is set for your directory"

    At the moment, i have no idea - how to solve this. I am grateful for any suggestions.
    Thanks in advance!

    Attached Files
  • Stephan
    Avatar
    Community Member
    55 Posts

    Re: Warnings after Installation on the WebServer Link to this post

    Hi experts,
    I do have exactly the same problem.
    Please help.
    What can we do ?

    TIA
    Stephan

  • anthias
    Avatar
    Community Member
    14 Posts

    Re: Warnings after Installation on the WebServer Link to this post

    Hello again.
    Except the warning outputs as described earlier I am getting this (see attached file) - when opening my url.

    Anyone any idea? Probably a common error output, isn't it?

    Attached Files
  • froschi
    Avatar
    Community Member
    2 Posts

    Re: Warnings after Installation on the WebServer Link to this post

    same probem here...

    any solutions so far ???

    greetings,

    froschi

  • Willr
    Avatar
    Forum Moderator
    5464 Posts

    Re: Warnings after Installation on the WebServer Link to this post

    Looks like you have safe_mod turned on in your php install. Some shared hosts do this. I think if you create a blank file '_ss_environment.php' file in the same folder as the one you have cms/ sapphire/ folders then it should get round this issue.

  • anthias
    Avatar
    Community Member
    14 Posts

    Re: Warnings after Installation on the WebServer Link to this post

    Yes! Thanks a lot! That solved the problem.
    Greets from Austria,
    T

  • froschi
    Avatar
    Community Member
    2 Posts

    Re: Warnings after Installation on the WebServer Link to this post

    this solution does'nt work for me.
    Safe_mode is "off" in my enviroment and
    putting the blank file '_ss_environment.php'
    to the silverstripe folder gives me:

    Warning: unlink(mysite/_config.php) [function.unlink]: Permission denied in /is/htdocs/wp1140410_VC24OHRC4B/www/install.php on line 709
    # Creating 'mysite/_config.php' for use with _ss_environment.php...
    # Creating /is/htdocs/wp1140410_VC24OHRC4B/www/mysite/_config.php
    # Creating '.htaccess' file...
    # Creating /is/htdocs/wp1140410_VC24OHRC4B/www/.htaccess

    Fatal error: SS_DATABASE_PASSWORD must be defined in your _ss_environment.php. See http://doc.silverstripe.com/doku.php?id=environment-management for more infomration in /is/htdocs/wp1140410_VC24OHRC4B/www/sapphire/conf/ConfigureFromEnv.php on line 46

  • Sam
    Avatar
    Administrator
    679 Posts

    Re: Warnings after Installation on the WebServer Link to this post

    You can't have a blank _ss_environment.php file - fill it out as instructed on http://doc.silverstripe.com/doku.php?id=environment-management

    3254 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.