Jump to:

4954 Posts in 14425 Topics by 1492 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » "Access to all CMS interfaces" not working?

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 903 Views
  • marco
    Avatar
    Community Member
    3 Posts

    "Access to all CMS interfaces" not working? Link to this post

    Hi,
    I've just installed SilverStripe 2.3.0 under Linux/PHP 5.2.9/MySQL 5.0.45. When I add a new user and give him "Access to all CMS interfaces" under Security/Permissions I cannot log in as said user (I get the message "I'm sorry, but you can't access that part of the CMS. If you want to log in as someone else, do so below"). If I add any other permission (say, "Access to 'Comments' (CommentAdmin)") I am able to log in and access the comments page. Each permission works as it should individually or combined with others (including adding "Access to all CMS interfaces", although this one doesn't seem to do anything). I see the following in the MySQL database:

    ID ClassName Created LastEdited Code Arg Type GroupID
    20 Permission    2009-03-12 15:50:59 2009-03-12 16:09:03 CMS_ACCESS_LeftAndMain    0 1 8

    The GroupID is correct, and contains only one member. For example, adding "Access to 'Comments' (CommentAdmin)", which allows the user to log in and edit comments, shows the following database entry:

    23 Permission 2009-03-12 16:24:12 2009-03-12 16:24:12 CMS_ACCESS_CommentAdmin    0    1    8

    Any ideas? Cheers!

    903 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.