Jump to:

4873 Posts in 7151 Topics by 1471 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » I'm not sure if it is installed successfully?

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 3665 Views
  • zcm211
    Avatar
    Community Member
    18 Posts

    I'm not sure if it is installed successfully? Link to this post

    The installing page shows below:

    Installing SilverStripe...
    I am now running through the installation steps (this should take about 30 seconds)

    If you receive a fatal error, refresh this page to continue the installation

    Creating 'mysite/_config.php'...
    Creating D:\Program Files\Apache Software Foundation\Apache2.2\webapp\SilverStripe\mysite/_config.php
    Creating '.htaccess' file...
    Creating D:\Program Files\Apache Software Foundation\Apache2.2\webapp\SilverStripe\.htaccess
    Building database schema...
    Checking that friendly URLs work...
    Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
    mod_rewrite is enabled
    AllowOverride All is set for your directory

  • gakenny
    Avatar
    Community Member
    153 Posts

    Re: I'm not sure if it is installed successfully? Link to this post

    Hello,

    The installation did not complete successfully. Please verify that this has been enabled:
    mod_rewrite is enabled
    AllowOverride All is set for your directory

    Cheers,

    Gary

  • zcm211
    Avatar
    Community Member
    18 Posts

    Re: I'm not sure if it is installed successfully? Link to this post

    I've already Load the rewrite model, doesn't it finish?

    LoadModule rewrite_module modules/mod_rewrite.so

    Although I did not install successfully, but I can use silverstripe normally. Should I ignore these warnings?

  • Sigurd
    Avatar
    Forum Moderator
    628 Posts

    Re: I'm not sure if it is installed successfully? Link to this post

    Looks like it is fine.

    SilverStripe 2.3.1 allows you to install without mod_rewrite being configured in the way SilverStripe needs; you just get slightly less user friendly URLs.

  • zcm211
    Avatar
    Community Member
    18 Posts

    Re: I'm not sure if it is installed successfully? Link to this post

    Thank you for your reply, I can continue my work.

  • Afterword
    Avatar
    Community Member
    5 Posts

    Re: I'm not sure if it is installed successfully? Link to this post

    how to make it work after this

    Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
    mod_rewrite is enabled
    AllowOverride All is set for your directory

    when try to go url: \silverstripe

    it write The requested page couldn't be found.

    what can i do to do this work?

  • Sigurd
    Avatar
    Forum Moderator
    628 Posts

    Re: I'm not sure if it is installed successfully? Link to this post

    Once you saw that error did it not carry on to show a working SilverStripe site?

    Please explain as much as you can about versions of your PHP, OS, etc, etc.

  • Afterword
    Avatar
    Community Member
    5 Posts

    Re: I'm not sure if it is installed successfully? Link to this post

    Yes, I don't see any default page, as write in tutorial.
    If it's error normal why i don't see first default page

    OS: Windows XP
    PHP : php-5.2.5-Win32
    Apache: Apache2.2

    3665 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.