Jump to:

4938 Posts in 16827 Topics by 1490 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Warning: failed to open dir...

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1619 Views
  • Sophie
    Avatar
    Community Member
    33 Posts

    Warning: failed to open dir... Link to this post

    I've recently created a site with Silver Stripe. When I first load the site in my browser, I receive the following warning:

    Warning: scandir(/home/content/o/n/l/onlygoodnews/html/themes/Page.ss) [function.scandir]: failed to open dir: Not a directory in /home/content/o/n/l/onlygoodnews/html/sapphire/core/ManifestBuilder.php on line 272

    Warning: scandir() [function.scandir]: (errno 20): Not a directory in /home/content/o/n/l/onlygoodnews/html/sapphire/core/ManifestBuilder.php on line 272

    I have no idea what this means! I've worked with SS a number of times and have never run into this. I've looked at the ManifestBuilder.php and this is line 272 referenced above.

    $items = scandir("$baseDir/$folder");

    If you refresh the page, the error message goes away and site works fine. The link to the site is [url=http://www.thegoodnews-paper.com]http://www.thegoodnews-paper.com

    I would really appreciate some guidance here. Thank you!

    Sophie

  • Sophie
    Avatar
    Community Member
    33 Posts

    Re: Warning: failed to open dir... Link to this post

    I figured this out. When FTPing files over I ended up dumping a file where it shouldn't be. Deleted that file and all is well.

    1619 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.