Jump to:

4873 Posts in 7260 Topics by 1471 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Silverstripe 2.3.1 on WS2008 IIS7 PHP5.9.2

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1912 Views
  • leinad
    Avatar
    Community Member
    7 Posts

    Silverstripe 2.3.1 on WS2008 IIS7 PHP5.9.2 Link to this post

    Hi,

    First time user here,

    PHP install seems fine - I can run phpinfo in a file in the silverstripe directory and returns fine
    but when I run install.php i get a standard Http 500 error

    I have attached phpinfo for review

    anyone any ideas what i'm doing wrong?
    Need more info - just ask and i'll supply

    Attached Files
  • Sigurd
    Avatar
    Forum Moderator
    628 Posts

    Re: Silverstripe 2.3.1 on WS2008 IIS7 PHP5.9.2 Link to this post

    When you have an Error 500 it will tell you more details in the server logs somewhere. You need to find this out so that it offers a clue.

    Curious: Why don't you use the Web Platform Installer to install SilverStripe?

  • leinad
    Avatar
    Community Member
    7 Posts

    Re: Silverstripe 2.3.1 on WS2008 IIS7 PHP5.9.2 Link to this post

    Hi and thanks for the reply,

    Tried to use the WebPI installer but was repeatedly getting download failures for some elements
    so i followed the links and downloaded manually and installed most features.

    as regards server log errors here is the one related to install.php in the IIS logs

    #Date: 2009-05-14 13:24:06
    #Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken
    2009-05-14 13:24:06 ::1 GET /SilverStripe-v2.3.1/install.php - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+1.1.4322;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30618) 500 0 0 296

    Thanks

  • leinad
    Avatar
    Community Member
    7 Posts

    Re: Silverstripe 2.3.1 on WS2008 IIS7 PHP5.9.2 Link to this post

    Hi,

    I was reading post251808 and i decided to try renaming php.ini as was suggested in the post and sure enough i now get the Silverstripe install screen, but gd2 or mysql not enabled now (php.ini was enabling these - see attachment from 1st post)

    any ideas what i can do?

    Thanks

  • leinad
    Avatar
    Community Member
    7 Posts

    Re: Silverstripe 2.3.1 on WS2008 IIS7 PHP5.9.2 Link to this post

    Hi Sigurd,

    Has Silverstripe been successfully installed on Windows Server 2008?

    Thanks

  • leinad
    Avatar
    Community Member
    7 Posts

    Re: Silverstripe 2.3.1 on WS2008 IIS7 PHP5.9.2 Link to this post

    for anyone interest solution is here
    install file is broken in download of 2.3.1

    http://www.silverstripe.org/installing-silverstripe/show/256795#post256795

    1912 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.