Jump to:

4897 Posts in 7127 Topics by 1473 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » IIS Install woes

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1874 Views
  • Yellow7 Jon
    Avatar
    Community Member
    39 Posts

    IIS Install woes Link to this post

    I've followed the install instructions, It not on a local server so I don't have too much control over it.

    I get to the install part, and get this error while its trying to install.

    heres the page output if that helps...

    # Creating 'mysite/_config.php'...
    # Creating D:\Domains\mhsrv.test\wwwroot\mysite/_config.php
    # Creating '.htaccess' file...
    # Creating D:\Domains\mhsrv.test\wwwroot\.htaccess
    # Building database schema...

    [User Error] DB::connect: Not passed a valid database config POST /install.php
    Line 71 in D:\Domains\mhsrv.test\wwwroot\sapphire\core\model\DB.php

    Trace

    * DB::connect: Not passed a valid database config Line 71 of DB.php
    * DB::connect(Array) Line 786 of install.php
    * Installer->install(Array) Line 123 of install.php

    After some research, I found this article which got me all sorted ( goto the bootnote at the bottom )

    http://cubiksoundz.blogspot.com/2008/12/tech-note-installing-silverstripe-cms.html

    contacted the host and got the privileges

  • stooni
    Avatar
    Community Member
    89 Posts

    Re: IIS Install woes Link to this post

    Create manually a _config.php file and upload with ftp to mysite folder with all data in it, database connect .

    <?php

    global $project;
    $project = 'mysite';

    global $databaseConfig;
    $databaseConfig = array(
       "type" => "MySQLDatabase",
       "server" => "localhost",
       "username" => "username",
       "password" => "password",
       "database" => "DatabaseName",
    );

    // Sites running on the following servers will be
    // run in development mode. See
    // http://doc.silverstripe.com/doku.php?id=devmode
    // for a description of what dev mode does.
    Director::set_dev_servers(array(
       'localhost',
       '127.0.0.1',
    ));
    // Enable Translations
    i18n::set_locale('de_DE');
    setlocale (LC_ALL, 'de_DE');

    // This line set's the current theme. More themes can be
    // downloaded from http://www.silverstripe.com/themes/
    SSViewer::set_theme('blackcandy');

    ?>

    And you have see these?

    http://doc.silverstripe.org/doku.php?id=installation-on-windows-manual-iis

    ----Stooni

    1874 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.