Jump to:

4876 Posts in 7042 Topics by 1473 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » problems after ubuntu upgrade

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1453 Views
  • twilliams1615
    Avatar
    Community Member
    1 Post

    problems after ubuntu upgrade Link to this post

    Silverstripe 2.2
    Apache/2.2.11
    PHP/5.2.6-3ubuntu4.2
    mysql 5.0.75-0ubuntu10.2
    Ubuntu 9.10 - Jaunty

    I upgraded Ubuntu last night from 8.10 to 9.04. After the upgrade was complete, silverstripe does not run. the sql server and apache is running. the DB is still intact. when browsing to the site, all i get is a tree of the files in /var/www/ but i cannot get my actual page to show.

    Index of /
    Name Last modified Size Description

    --------------------------------------------------------------------------------

    COPYING 26-Aug-2009 10:16 1.5K
    ChangeLog 26-Aug-2009 10:16 48K
    INSTALL 26-Aug-2009 10:16 647
    Makefile 26-Aug-2009 10:16 460
    UPGRADING 26-Aug-2009 10:16 1.1K
    assets/ 26-Aug-2009 10:16 -
    batchfiles/ 26-Aug-2009 10:16 -
    bothmon.html 26-Aug-2009 10:16 378
    calendar.html 26-Aug-2009 10:16 294
    close.php 26-Aug-2009 10:16 131
    cms/ 26-Aug-2009 10:17 -
    favicon.ico 26-Aug-2009 10:16 1.1K
    helpful/ 26-Aug-2009 10:17 -
    images/ 26-Aug-2009 10:17 -
    jsparty/ 26-Aug-2009 10:17 -
    mysite/ 26-Aug-2009 10:56 -
    sapphire/ 26-Aug-2009 10:20 -
    themes/ 26-Aug-2009 10:21 -
    trial/ 26-Aug-2009 10:21 -
    tutorial/ 26-Aug-2009 10:21 -

    --------------------------------------------------------------------------------

    Here is .htaccess

    ### SILVERSTRIPE START ###
    RewriteEngine On
    RewriteBase /

    RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

    RewriteCond %{REQUEST_URI} ^(.*)$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
    ### SILVERSTRIPE END ###

    anybody else have this problem or any suggestions on fixing it?

  • NARKOZ
    Avatar
    Community Member
    25 Posts

    Re: problems after ubuntu upgrade Link to this post

    Check chmod atributes of files. Make sure that php scripts have run permissions.

  • acidzfire
    Avatar
    Community Member
    1 Post

    Re: problems after ubuntu upgrade Link to this post

    Thanks for the reply. I checked all permissions, and they are the same as they were previous to the upgrade. I even went as far as to change everything in /var/www/ to 777 to be sure. I still get just the listing of the files.

    1453 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.