Jump to:

4952 Posts in 14256 Topics by 1491 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Multiple installs on IIS 7?

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1071 Views
  • dynamite
    Avatar
    Community Member
    66 Posts

    Multiple installs on IIS 7? Link to this post

    Hello,

    Has anyone successfully had multiple SS installs on IIS 7?

    When I try to set it up, it seems they keep overwriting each other somehow and I have to disable one and run a new /dev/build for the initial site to work again.

    I am using the same IP address, but have the "bindings" set to different host names.

    I am very familiar with Apache, relatively good on SS on Linux, but not so hot on IIS. Any pointers or ideas would be *wonderful*!

    Thank you,

    Jeremy

  • dynamite
    Avatar
    Community Member
    66 Posts

    Re: Multiple installs on IIS 7? Link to this post

    I was able to get a work-around done: it was writing to the same "C:\Windows\Temp\silverstripe-cache" folder. Something is not working with the regular expression because of the Windows back-slashes. See:

    http://www.silverstripe.org/installing-silverstripe/show/264829#post264829

    I couldn't get the above to work, so I just hard-coded the folder to be "silverstripe-cache-2" in a couple different places in sapphire/core/core.php

    1071 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.