Jump to:

4938 Posts in 16764 Topics by 1490 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » SS .htaccess issue - Please help me

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1399 Views
  • valentin83
    Avatar
    Community Member
    13 Posts

    SS .htaccess issue - Please help me Link to this post

    I have a big problem. I have a problem with some rules and conditions from .htaccess file, the file looks like this:

    RewriteEngine On

    RewriteCond %{REQUEST_URI} ^(.*)$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]

    I have installed it on my server @ GoDaddy and works fine, also I have on the same hosting account a subdomain with the same script and also he work just fine as well. Now here is the thing: I have two more add-on domain there and uploaded 2 more websites, when I'm using the standard .htaccess file with SS rules and conditions the sites using this script work but the others (plain .html sites) are not working (500 Internal Server Error), and if I remove and upload a standard or 0 bytes .htaccess file plain html sites work but your script is looking like a skinned site (no css at all - not even the browser's) - after looking at the problem deeper I figured it needs to be linked to saphire in the .htaccess file to look like it should. I've addressed myself to the hosting support center and they indicated the same root of the problem: .htaccess file is corrupted.

    This is out of my hands and I can't figure out what to add to that file or what to remove so that those sites coexist like any websites should on a web-server.

    Thanks, and I would appreciate an answer A.S.A.P.

  • Taffy
    Avatar
    Community Member
    119 Posts

    Re: SS .htaccess issue - Please help me Link to this post

    You may also want to try asking the question on the IRC channel http://irc.silverstripe.org/cgi-bin/irc.cgi

  • valentin83
    Avatar
    Community Member
    13 Posts

    Re: SS .htaccess issue - Please help me Link to this post

    Thanks you for your suggestion, I will because I really need to solve this issues, it's really messing up my hosting account.

  • valentin83
    Avatar
    Community Member
    13 Posts

    Re: SS .htaccess issue - Please help me Link to this post

    Meanwhile feel free to repospond here if you know what's happening and why do I have those errors.

    1399 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.