Jump to:

324 Posts in 153 Topics by 156 members

Migrating a Site to Silverstripe

SilverStripe Forums » Migrating a Site to Silverstripe » Internal Server Error issue

What you need to know when migrating your existing site to SilverStripe.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 3516 Views
  • Heike-san
    Avatar
    Community Member
    52 Posts

    Re: Internal Server Error issue Link to this post

    It seems like the folder is read only and that the .htaccess is disappearing from the site tree each time a upload it.
    I am going to make the proper changes and I will let you know!!

  • Heike-san
    Avatar
    Community Member
    52 Posts

    Re: Internal Server Error issue Link to this post

    So I have checked:
    .htaccess is present remotly
    permissions on the files are OK
    remove the DirectorySlash and <Files *.ss> directives : Done
    mod_rewrite is properly installed: Dunno how to check that but it works locaaly so mod_rewrite should be installed

    It is still not working!!

  • banal
    Avatar
    Community Member
    901 Posts

    Re: Internal Server Error issue Link to this post

    A working local installation doesn't necessarily work on a remote machine. Are you using the onedoor directory locally and on the remote machine?

  • Heike-san
    Avatar
    Community Member
    52 Posts

    Re: Internal Server Error issue Link to this post

    Yeah I am using it on both but I finally work it out, mod_rewrite was the issue I needed to change the SERVER_SIGNATURE to SERVER_SOFTWARE in install.php and remove RewriteBase from the .htaccess.

  • Heike-san
    Avatar
    Community Member
    52 Posts

    Re: Internal Server Error issue Link to this post

    In fact,it is still not working, something is causing major bugs on the cms side.
    Though I granted all the privileges on the .htaccess files I whenever i try to edit a page in the cms i got a blank or warning/error page!!

  • OwenW
    Avatar
    Community Member
    45 Posts

    Re: Internal Server Error issue Link to this post

    Heike-san,

    Out of interest, What OS are you running this under?

    With the error page that you are getting returned, Is it from Silverstripe or from the webserver itself?

  • Heike-san
    Avatar
    Community Member
    52 Posts

    Re: Internal Server Error issue Link to this post

    The OS is Windows Xp or Vista (depending that I am working from home or at the office).
    And the error seems to come from the server.
    Although I think I've settled the matter by using the content of previous websites cms and sapphire folder.
    Turns out it works okay, but I haven't fully tested the website though so not 100% sure.

  • vstrazz
    Avatar
    Community Member
    63 Posts

    Re: Internal Server Error issue Link to this post

    What version of PHP are you running?

    3516 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.