Jump to:

655 Posts in 2084 Topics by 163 members

Releases and Announcements

SilverStripe Forums » Releases and Announcements » SilverStripe 2.4.0-alpha1 to stable?

Latest news about the SilverStripe software.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1342 Views
  • swaiba
    Avatar
    Forum Moderator
    1784 Posts

    SilverStripe 2.4.0-alpha1 to stable? Link to this post

    Hi,

    Do you have an idea when you might be officially releasing a stable 2.4 please?

    Barry

  • Taffy
    Avatar
    Community Member
    119 Posts
  • swaiba
    Avatar
    Forum Moderator
    1784 Posts

    Re: SilverStripe 2.4.0-alpha1 to stable? Link to this post

    Taffy thank you very much for the link, I have been watching this over the last couple of months. Unfortunately it still doesn't give me an idea when I might expect to be able to rely on the 2.4 platform. This is critically important as Model Admin seems very unstable before 2.4... in the time I have left for my project I need to either know I can use 2.4 or make 2.3.6 ModelAdmin work without issue

  • Willr
    Avatar
    Forum Moderator
    5482 Posts

    Re: SilverStripe 2.4.0-alpha1 to stable? Link to this post

    Hmm funny I had backported some of the bugfixes for ModelAdmin to 2.3 so if you could clarify what major bugs you are encountering that would be good. Then at least branches/2.3 is stable.

    Next beta / rc release is due very soon. Then I guess it will be a few weeks, maybe up to a month after that next release before an official stable. Though we have been running 2.4 for a while so you might be looking to upgrade to the next beta / rc since the API should have been locked down by then.

  • swaiba
    Avatar
    Forum Moderator
    1784 Posts

    Re: SilverStripe 2.4.0-alpha1 to stable? Link to this post

    Hi Will,

    Thanks for your response, I have spent quite a while trying to workout what is going on without any results...

    There were problems with the export to csv, but I couldn't reproduce that right away (maybe it was in 2.3.5 and fixed now?).

    the issue I see over and again relates to validation, I have prepared a full description of this and attached it to this post... basically when a field fails validation the screen resets itself to the welcome screen instead of leaving you on the record edit screen with he validation error feedback... this is within 2.3.6 and across browsers (ie/chrome/ff)

    Barry

    1342 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.