Jump to:

3445 Posts in 1031 Topics by 872 members

Template Questions

SilverStripe Forums » Template Questions » Template overriding

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1950 Views
  • volker
    Avatar
    Community Member
    4 Posts

    Template overriding Link to this post

    Hi,

    the documentation about themes development at http://doc.silverstripe.com/doku.php?id=themes:developing mentions that templates can be overridden in the folders "mysite", "themes" and "module" where templates from "mysite" get the highest and the ones from the module directory the lowest priority. This seems reasonable to me, but unfortunately this isn't true for SS 2.3.0-rc2. Instead the templates from the themes folder override the ones from "mysite".

    I searched around and found an older forum entry "Themes in v2.1.0" (http://silverstripe.org/archive/show/6623) where this question was discussed already for older SS versions - unfortunately without any resolution (and the entry was read-only, that's why I open a new entry for this issue here).

    What's the status of this problem? Will it be resolved in the future or will the documentation be updated to reflect the real behavior?

    Thanks,
    Volker

  • Hamish
    Avatar
    Community Member
    712 Posts

    Re: Template overriding Link to this post

    Yeah, that should really be changed, although it could impact a lot of people.

    Ticket and patch raised here: http://open.silverstripe.com/ticket/3300

  • volker
    Avatar
    Community Member
    4 Posts

    Re: Template overriding Link to this post

    Thank you for the fast patch!

    I've just double-checked that it works fine for me.

    Are there any estimations if this change will be in the next official 2.3 release?

    Regards,
    Volker

  • Hamish
    Avatar
    Community Member
    712 Posts

    Re: Template overriding Link to this post

    I doubt that it would be. 2.3 is right at the end of release candidate phase, and this sort of change could trip a lot of people up.

    SSViewer is pretty stable though. Nothing wrong with applying the patch to your installation, and using 2.3 for everything else - should work fine.

    1950 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.