Jump to:

3392 Posts in 976 Topics by 852 members

Template Questions

SilverStripe Forums » Template Questions » Dynamic content grid possible?

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 4423 Views
  • pivey
    Avatar
    Community Member
    11 Posts

    Re: Dynamic content grid possible? Link to this post

    Hi Kevin,

    do you know if page-elements can (and how) be adjusted to work on multilingual web site?

    Main issues i have are that
    1. editing a grid.ss layout page, changes will not be taken unless by workaround to choose "back" a empty template, then assign the grid layout again to that page.

    2. when cliking to edit a section, but you don't do anything at all... instead just "close" the edit window, the DrigPage shows empty (blank). Only when choosing again the GridPage on admin left menu, content shows up again proper.

    3. Some of the icons (like edit, close etc) are not displayed any more, tried almost everything. Can not explain behaviour.

    IE8 onlyissues:
    1. popup window to edit does full size on browser, not within screen, like it should. You have to use "back" button to see admin area again.

    2. GridPage is not loaded on first click (needs to be clicked twice)

    Could you help on some of these issues?
    Thanks for your comments

  • t|m
    Avatar
    Community Member
    19 Posts

    Re: Dynamic content grid possible? Link to this post

    Hi pivey,

    I've never tried running the module in a multilingual environment but it should be fairly straight forward.
    Have a look at http://doc.silverstripe.org/sapphire/en/topics/translation

    I've heard a few people seem to have these issues - I cant replicate them.

    If you can - try with older SS versions 2.4.1 seemed to run very stable.
    I will look through these issues as soon as I have some spare time.

    Also I need to set up a public bug tracker as the current one is getting abused by spam bots...

    Hope this helps you a little.

    Cheers,
    Tim

  • pivey
    Avatar
    Community Member
    11 Posts

    Re: Dynamic content grid possible? Link to this post

    Hi Tim,

    thanks for your help.
    Where can i get older versions of SilverStripe?

    Will set up in Multilingual and let you know when all runs fine.
    However, regarding my issues i would really appreciate if you can advice with fixes, as a project i will probably need to run page-elements with new SS versions.

  • t|m
    Avatar
    Community Member
    19 Posts

    Re: Dynamic content grid possible? Link to this post

    Hi,

    which version of pe are you using?
    I've only just recently updated the 'module' on this site to 2.2

    This works fine with 2.4.5 for me...

    cheers

  • pivey
    Avatar
    Community Member
    11 Posts

    Re: Dynamic content grid possible? Link to this post

    Hi,

    i am on Version 2.4.5 as well.
    Will test again and report issues with screenshots

    forgot to say that it is all done locally using wamp server, will track if any issues related there

  • pivey
    Avatar
    Community Member
    11 Posts

    Re: Dynamic content grid possible? Link to this post

    i was away for a long time. Meanwhile i tested locally & live on my server. The same issues i have locally are also on live server.
    GridPage looses database connection on when trying to create new element part, returns "error" on saving, and IE8 still does open popup window in full screen.

    i have attached a file of screenshots for your convinience

    Attached Files
    4423 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.