Jump to:

1385 Posts in 493 Topics by 522 members

Themes

SilverStripe Forums » Themes » Problem installing theme

Discuss SilverStripe Themes.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3
Go to End
Author Topic: 4135 Views
  • Daver
    Avatar
    Community Member
    1 Post

    Problem installing theme Link to this post

    If anyone can help me, I would appreicate it.

    I am a very new silverstripe user and was attempting to swap out the default theme in favor of "darkshades".

    I extracted darkshades into the "themes" directory and switched /mysite/_config.php to read:
    SSViewer::set_theme('darkshades');

    Instead of a nifty change I get:

    The page isn't redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    * This problem can sometimes be caused by disabling or refusing to accept
    cookies.

    So I erased all the cache files in /silverstripe-cache and ran www.domain.com?flush=1 and no change.

    So I changed _config.php back to "blackcandy" and still get the redirect error.

    So I flushed the cache again and no luck.

    Basically the system is dead now, where it was working all afternoon. While I can just "start over", I'd rather figure out what the problem is. Admin screens don't work either.

    Thanks in advance,

    Dave

  • Nivanka
    Avatar
    Community Member
    395 Posts

    Re: Problem installing theme Link to this post

    just to give you some help!.

    dont you think whether if is a .htaccess problem?

    also is your home page is a normal page?

  • pankh
    Avatar
    Community Member
    1 Post

    Re: Problem installing theme Link to this post

    sir
    i m new user
    i have a problem to up lode the theme

    when i download the theme files
    but dont know how to change theme name

    please help

  • Ryan M.
    Avatar
    Community Member
    309 Posts

    Re: Problem installing theme Link to this post

    I'm having the same problem, but I'm experienced with SS. This seems to be a problem with the latest version 2.3.6. My old version of 2.3.4 never had this problem.

    Any help, admins?

  • Venomous
    Avatar
    Community Member
    1 Post

    Re: Problem installing theme Link to this post

    Hi,

    I'm very new to SilveStripe also, and I'm having issues installing new themes.

    My issues are exactly the same as yours, and I'm unable to find half the stuff in _config.php in order to change the theme.

    Apart from that, SS look's fantastic!

    Ven.

  • patjnr
    Avatar
    Community Member
    101 Posts

    Re: Problem installing theme Link to this post

    hi all

    You can try /?flush=all

    P

  • lentotski
    Avatar
    Community Member
    1 Post

    Re: Problem installing theme Link to this post

    ?flush=all works. thanks!

  • Herries
    Avatar
    Community Member
    12 Posts

    Re: Problem installing theme Link to this post

    I've found that if you change anything in the mysite/_config.php file, it permanently disables the whole silverstripe installation. I see other people have encountered this as well. This is a SERIOUS flaw that the silverstripe team should address. I've spent an entire day trying to find a fix but the only solution is a clean insall. Arrrrrrrgggggghhhhhhhh!!!

    4135 Views
Page: 1 2 3
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.