Jump to:

1374 Posts in 487 Topics by 520 members

Themes

SilverStripe Forums » Themes » Bootstrap on SS not working

Discuss SilverStripe Themes.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 164 Views
  • tahbit
    Avatar
    Community Member
    22 Posts

    Bootstrap on SS not working Link to this post

    Hi everyone,

    Ok - I have wasted too much time on this. I cannot get Bootstrap to work on SS. I cannot even get a dropdown menu to work. Are there any resources that demonstrate how to implement Bootstrap JS into SS?

    I really don't want to go down the road of a wholesale BS theme. I've created my own - I have designed static pages and I know without SS it works fine. The JS files are loading correctly as are the relevant plugins (collapse etc) but SS just won't play with BS.

    Surely somebody must have had a similar problem or if not what did you do to get the BS JS to work?

    Many thanks!

  • tahbit
    Avatar
    Community Member
    22 Posts

    Re: Bootstrap on SS not working Link to this post

    I have sorted it! The reason for the problem was that I tried to introduce BS over the top of the Simple theme. When I started from scratch with my own theme - no defaults set, everything worked correctly.

    Lesson learned!

    164 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.