Jump to:

1136 Posts in 1984 Topics by 403 members

Upgrading SilverStripe

SilverStripe Forums » Upgrading SilverStripe » 2.4.0 Beta Upgrade Errors

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1117 Views
  • pingu
    Avatar
    Community Member
    75 Posts

    2.4.0 Beta Upgrade Errors Link to this post

    Hi,

    I'm trying to upgrade a local version of a website from 2.3.1 -> 2.4 Beta, and I'm getting some errors.
    I've deleted the cms and sapphire folders and overwritten with what's included in the 2.4 package, but the error I'm getting is:
    Fatal error: Class 'SS_Database' not found in \sapphire\core\model\MySQLDatabase.php on line 10

    If I then proceed to copy over the googlesitemaps folder, I initially get a few more errors, which later disappear:

    Notice: Undefined index: GoogleSitemapDecorator in \sapphire\core\ManifestBuilder.php on line 447

    Warning: There are two files both containing the same class: '/googlesitemaps/code/GoogleSitemap.php' and ''. This might mean that the wrong code is being used. in \sapphire\core\ManifestBuilder.php on line 449

    Notice: Undefined index: GoogleSitemap in \sapphire\core\ManifestBuilder.php on line 447

    Warning: There are two files both containing the same class: '/googlesitemaps/code/GoogleSitemap.php' and ''. This might mean that the wrong code is being used. in \sapphire\core\ManifestBuilder.php on line 449

    Notice: Undefined index: GoogleSitemapDecorator in \sapphire\core\ManifestBuilder.php on line 447

    Warning: There are two files both containing the same class: '/googlesitemaps/code/GoogleSitemapDecorator.php' and ''. This might mean that the wrong code is being used. in \sapphire\core\ManifestBuilder.php on line 449

    Would appreciate any help with this? I'd like to avoid a clean install if I can just upgrade...

  • pingu
    Avatar
    Community Member
    75 Posts

    Re: 2.4.0 Beta Upgrade Errors Link to this post

    Okay, as it turns out I just had to empty the silverstripe-cache directory, and all is well.
    Woops.

    1117 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.