Jump to:

1136 Posts in 1984 Topics by 403 members

Upgrading SilverStripe

SilverStripe Forums » Upgrading SilverStripe » Upgrade 2.3.3 to 2.3.6 template problems

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 769 Views
  • arthurdent
    Avatar
    Community Member
    133 Posts

    Upgrade 2.3.3 to 2.3.6 template problems Link to this post

    Hi, hope someone can offer me some advice. I just installed a clean copy of SS 2.3.6 onto a development server. Tested using the Blackcandy theme and then updated and uploaded my _config.php file and the theme that I had designed for my client that HAD been working under SS 2.3.3. Fired the site up and got the following screen:

    Source

    166                $this->chosenTemplates['main'] = $this->chosenTemplates[$templateFolder];
    167                unset($this->chosenTemplates[$templateFolder]);
    168             }
    169          }
    170
    171          if(isset($_GET['debug_request'])) Debug::message("Final template selections made: " . var_export($this->chosenTemplates, true));
    172
    173       }
    174
    175       if(!$this->chosenTemplates) user_error("None of these templates can be found: ". implode(".ss, ", $templateList) . ".ss", E_USER_WARNING);
    176
    177       parent::__construct();
    178    }
    179    
    180    /**
    181     * Returns true if at least one of the listed templates exists

    Trace

    * None of these templates can be found: Page.ss, ContentController.ss
    Line 175 of SSViewer.php
    * SSViewer->__construct(Array)
    Line 305 of Controller.php
    * Controller->getViewer(index)
    Line 172 of Controller.php
    * Controller->handleAction(HTTPRequest)
    Line 129 of RequestHandler.php
    * RequestHandler->handleRequest(HTTPRequest)
    Line 119 of Controller.php
    * Controller->handleRequest(HTTPRequest)
    Line 29 of ModelAsController.php
    * ModelAsController->handleRequest(HTTPRequest)
    Line 44 of RootURLController.php
    * RootURLController->handleRequest(HTTPRequest)
    Line 280 of Director.php
    * Director::handleRequest(HTTPRequest,Session)
    Line 121 of Director.php
    * Director::direct(/)
    Line 118 of main.php

    Apparently it's something to do with line 175 - can anybody tell me what the zark is going on?

  • arthurdent
    Avatar
    Community Member
    133 Posts

    Re: Upgrade 2.3.3 to 2.3.6 template problems Link to this post

    Upon re-reading my post one thing's pretty obvious - line 175 generates a list of things that Sapphire wants but can't find. Trouble is, I don't know why it wants them at this stage? Weren't they there under 2.3.3? What are they?

    Any assistance appreciated!

    769 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.