Jump to:

1160 Posts in 2621 Topics by 409 members

Upgrading SilverStripe

SilverStripe Forums » Upgrading SilverStripe » Site Tree Flakiness after upgrade to 2.4.5

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 950 Views
  • bhowell
    Avatar
    Community Member
    2 Posts

    Site Tree Flakiness after upgrade to 2.4.5 Link to this post

    I just upgraded to 2.4.5 and things look good except for the backend which is sometimes displaying an incomplete site-tree. Some of the base nodes are there but any pages in the site tree with children (the important ones!) don't show up in the CMS panel. The front end is rendering fine.

    This is really weird and does not seem to have to do with the cache on the server side as flushing as well as deleting the cache files does not seem to help. It seems like the browser is getting some kind of corrupted or incomplete AJAX bits and caching it. The one thing that seemed to work was switching tabs in the CMS and then doing a shift-refresh to clear the browser cache. This happens on Firefox, Chrome and Safari.

    Any help or suggestions would be great as my users are a little annoyed and confused.

  • Howard
    Avatar
    Community Member
    215 Posts

    Re: Site Tree Flakiness after upgrade to 2.4.5 Link to this post

    That's odd - havent experienced it myself.

    Perhaps a file got corrupted but either way you could try updating to 2.4.6 and see if that resolves the issue.

    Howard

  • Howard
    Avatar
    Community Member
    215 Posts

    Re: Site Tree Flakiness after upgrade to 2.4.5 Link to this post

    That's odd - havent experienced it myself.

    Perhaps a file got corrupted but either way you could try updating to 2.4.6 and see if that resolves the issue.

    Howard

  • JC
    Avatar
    Community Member
    1 Post

    Re: Site Tree Flakiness after upgrade to 2.4.5 Link to this post

    Hi bhowell,

    Just wondering if this issue was ever solved? I am experiencing a very similar issue after upgrading.

    Cheers,

  • bhowell
    Avatar
    Community Member
    2 Posts

    Re: Site Tree Flakiness after upgrade to 2.4.5 Link to this post

    Hi JC,

    We still have the same problem. I gave up trying as we are going with another CMS solution as part of a site re-design. But if you find a solution do share.

    950 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.