Jump to:

1161 Posts in 2632 Topics by 409 members

Upgrading SilverStripe

SilverStripe Forums » Upgrading SilverStripe » Wrong headers sent on 302 redirect

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 558 Views
  • heidgert
    Avatar
    Community Member
    16 Posts

    Wrong headers sent on 302 redirect Link to this post

    I have just upgraded a 2.4x site to 3.0.1 successfully (http://www.music-streamer.com).

    I am running it on Windows Server 2008 and IIS 7.

    The problem I'm having is that when going to the admin url (http://www.music-streamer.com/admin) the browser gets stuck.

    I have narrowed it down by using Fiddler, and it looks like the server is returning an invalid response. Where the HTTP headers should start it is some html returned instead.

    Here is what is returned (text originally viewed in hex-mode, sorry for the formatting):

    <head><title>Document Mo
    ved</title></head>.<body
    ><h1>Object Moved</h1>Th
    is document may be found
    <a HREF="http://www.mus
    ic-streamer.com/admin/pa
    ges/">here</a></body>HTT
    P/1.1 302 Found..Cache-C
    ontrol: no-store, no-cac
    he, must-revalidate, pos
    t-check=0, pre-check=0..
    Pragma: no-cache..Conten
    t-Length: 0..Content-Typ
    e: text/html; charset=UT
    F-8..Expires: Thu, 19 No
    v 1981 08:52:00 GMT..Loc
    ation: http://www.music-
    streamer.com/Security/lo
    gin?BackURL=%2Fadmin%2Fp
    ages%2F..Server: Microso
    ft-IIS/7.0..X-Powered-By
    : PHP/5.3.10..X-Controll
    er: CMSPagesController..
    X-Title: SilverStripe -
    Pages..X-Powered-By: ASP
    .NET..Date: Tue, 31 Jul
    2012 17:49:45 GMT....<he
    ad><title>Document Moved
    </title></head>.<body><h
    1>Object Moved</h1>This
    document may be found <a
    HREF="http://www.music-
    streamer.com/Security/lo
    gin?BackURL=%2Fadmin%2Fp
    ages%2F">here</a></body>

    This makes me have to do some manual refreshes to be able to log in.

    Has anybody else had the same problems, or have a solution for this?

    558 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.