Jump to:

1136 Posts in 1984 Topics by 403 members

Upgrading SilverStripe

SilverStripe Forums » Upgrading SilverStripe » 404 page after upgrading from 2.4.5 to 3.0.3

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 415 Views
  • Harley
    Avatar
    Community Member
    153 Posts

    404 page after upgrading from 2.4.5 to 3.0.3 Link to this post

    Hi there,

    I recently tested out upgrading on my local site before making the jump to 3.0.3 on my live site. So after deleting the cms and saphire folders and replacing them with cms and framework I am getting a 404 error. All modules have been removed, index.php replaced and no joy.

    Can anyone assist here?

    Thanks in advance!

    Regards

  • simon_w
    Avatar
    Forum Moderator
    467 Posts

    Re: 404 page after upgrading from 2.4.5 to 3.0.3 Link to this post

    You also need to update the reference in the .htaccess file from sapphire/main.php to framework/main.php.

  • Harley
    Avatar
    Community Member
    153 Posts

    Re: 404 page after upgrading from 2.4.5 to 3.0.3 Link to this post

    Thanks Simon,

    I've made the change as you suggested to the htaccess file but still getting a 404. Is there anywhere else sapphire might be referenced from?

    Regards

    415 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.