Jump to:

1155 Posts in 2568 Topics by 408 members

Upgrading SilverStripe

SilverStripe Forums » Upgrading SilverStripe » Javascript Sizzle error in 3.1.0-rc1

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1050 Views
  • liefra
    Avatar
    Community Member
    5 Posts

    Javascript Sizzle error in 3.1.0-rc1 Link to this post

    Hi all,

    I'm trying to upgrade a site to 3.1.0-rc1 and receive a Javascript Sizzle error after clicking on the "Create" button on the "Add page" CMS page.

    Steps to reproduce:
    1) Click "Add new" in the pages section of the CMS
    2) Select "Top Level" and "Page" pagetype and click "Create"
    3) This is make the add page ajax request and does lead to the following Javascript error:
    Error: Syntax error, unrecognized expression:[Break On This Error]    
    var ret = matches.call( node, expr );
    4) The new pages does NOT appear. But actually it is being created and if I refresh the CMS, then the new page shows up as draft page

    If I update the jQuery to 1.8.3, then the error goes away, but the CMS throws all sorts of other errors, so this seems to be no solution

    The error does not occur in all SilverStripe website which I have tested. Another, more simple site, is running successfully on 3.1.0-rc1

    Anybody else did see this already? Or any ideas of how this could be solved?

    Thanks and best regards
    Frank

  • SSPenguin
    Avatar
    Community Member
    2 Posts

    Re: Javascript Sizzle error in 3.1.0-rc1 Link to this post

    I got the same error here as well when i try to add a new data object in the cms.

    Attached Files
  • SSPenguin
    Avatar
    Community Member
    2 Posts

    Re: Javascript Sizzle error in 3.1.0-rc1 Link to this post

    fixed just now, i removed the spaces between my classes the <?php tag

  • liefra
    Avatar
    Community Member
    5 Posts

    Re: Javascript Sizzle error in 3.1.0-rc1 Link to this post

    Hi SSPenguin

    thanks a lot for posting your solution. Could you please be a bit more detailed with your solution, as I have removed several spaces, but it still doesn't work.

    For instance my Page.php class starts with:
    <?php
    class Page extends SiteTree {

    private static $db = array(
    );
    .....

    Best regards
    Frank

  • liefra
    Avatar
    Community Member
    5 Posts

    Re: Javascript Sizzle error in 3.1.0-rc1 Link to this post

    Just a short follow up. For me, the problem was related to the widgets plugin. I just updated this, and now all works fine again

    Best, Frank

  • Mojo5000
    Avatar
    Community Member
    5 Posts

    Re: Javascript Sizzle error in 3.1.0-rc1 Link to this post

    I just came across something very similar, it is driving me nuts. Not sure what changed.

    Can you be explicit with what you changed?

    SOLVED:

    Doh.

    -----

    <?php

    Left a line break above the <?php for one of my Page.php files. This was causing it not to load and therefore held up the -Pages link within the CMS.

    1050 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.