Jump to:

1161 Posts in 2632 Topics by 409 members

Upgrading SilverStripe

SilverStripe Forums » Upgrading SilverStripe » Problem with migration site from 2.2.3 to 2.3.rc3

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1188 Views
  • jezikk
    Avatar
    Community Member
    10 Posts

    Problem with migration site from 2.2.3 to 2.3.rc3 Link to this post

    Hi all,

    I have a site with ~3,5k pages (mostly news) and about 1k images. I decided to update cms to new version for some resons (e.g. TinyMCE).

    I did a whole backup of the site, put new files to server, run /dev/build and this gone ok.
    Problems started when i wanted to login to admin area. I get at the beginning error 500, after some code optimisation it get the SiteTree area working. Unfortunately and other custom made modules, google sitemap and MOST IMPORTANT ASSETS area not working.

    Lets start with problems:
    1. Assets area cause error 500 when loading (php memory limit is set to 1G, in error log:
    - Connection reset by peer: FastCGI: comm with server "/usr/local/apache/fcgi-bin/php5-fcgi" aborted: read failed, referer: XXXXX.com/admin
    - FastCGI: incomplete headers (0 bytes) received from server "/usr/local/apache/fcgi-bin/php5-fcgi", referer: XXXXX.com/admin/
    )
    2. Custom made modules - directories are in the root folder however in admin menu there are no links.
    3. Googlesitemap - Allowed memory size of 1G exhausted (tried to allocate 2G)

    Can anybody help me with this problems ?

    1188 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.