Jump to:

794 Posts in 408 Topics by 304 members

Widgets

SilverStripe Forums » Widgets » No frontend Widgets after upgrading to 2.4

Discuss SilverStripe Widgets.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1606 Views
  • Martijn
    Avatar
    Community Member
    271 Posts

    No frontend Widgets after upgrading to 2.4 Link to this post

    After upgrading to 2.4 my widgets are lost in frontend. They do show up in the CMS.

    I use the widgets like the docs describe and that worked in 2.3.x:

    http://doc.silverstripe.org/widgets

    I saw in Sapphire that there has changed a lot, but I'm not able to get my Widgets back...

  • Martijn
    Avatar
    Community Member
    271 Posts

    Re: No frontend Widgets after upgrading to 2.4 Link to this post

    A Table Field Enabled is added to the WidgetTable....

    They where set to 0.....

  • DsX
    Avatar
    Community Member
    178 Posts

    Re: No frontend Widgets after upgrading to 2.4 Link to this post

    I checked this entry in my DB and things were ok.
    Did this setting solve your problem?

    Please if you can read my other post: http://www.silverstripe.org/widgets-2/show/285204#post285204
    you may have some insight I do not since I never used widgets in 2.3

  • aarono
    Avatar
    Community Member
    34 Posts

    Re: No frontend Widgets after upgrading to 2.4 Link to this post

    any luck with this? i'm having the same problems

  • speedofmac
    Avatar
    Community Member
    10 Posts

    Re: No frontend Widgets after upgrading to 2.4 Link to this post

    I'd really like to know if someone got this working. I followed the instructions at http://doc.silverstripe.org/widgets, and the widget tab appears in the backend, and everything seems fine, but the widgets aren't appearing in the frontend. An easy way to add widgets to the sidebar of a page might convince me that it would be easier for me to manage a page using SilverStripe on the server side than is using TemplateToolkit client-side.

  • DsX
    Avatar
    Community Member
    178 Posts

    Re: No frontend Widgets after upgrading to 2.4 Link to this post

    I haven't had any luck. Have been able to get a number of other things happening in 2.4 but not widgets (other than those that come with the blog module. Is there any reason that these should work and not others?)

    So, since you have the widget tab appearing you must have the code in page.php in place. Thats the same point i have got to.

    I am testing the page-elements module (the trunk works with 2.4 details can be found on the developers site). It gives me the ability to have multiple sidebars (or any other holder) and load 'elements' into each. An element is much like a widget, a few are supplied and you can create more if you need...

    Anyway... until I get widgets workin I am happy with this solution.

    1606 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.