Jump to:

794 Posts in 409 Topics by 304 members

Widgets

SilverStripe Forums » Widgets » RandomContentWidget not saving state

Discuss SilverStripe Widgets.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1331 Views
  • RichardMortimer
    Avatar
    Community Member
    15 Posts

    RandomContentWidget not saving state Link to this post

    Hi,

    We've recently come up against an issue where we add a RandomContentWidget to a page, tell it the URL, and save the page, to go back again and the widget is not saved to the page.

    The odd thing is, this was working a while ago, and we added the widget to a number of pages, which all seems to be working, it's only when we try to add a new RCW in.

    Checking the database, I looked up the ID of some of the pages we're having problems with, and in the RandomContentWidget table, the ParentPage field is set, and is the correct page.

    Anyone have any ideas about what I might be doing wrong?

    Thanks

    Richard

  • RichardMortimer
    Avatar
    Community Member
    15 Posts

    Re: RandomContentWidget not saving state Link to this post

    As an update, I added the IE6 detection widget to the site, and installed on a couple of pages as a test, and this is not saving either; with either a page that has previously had a widget installed, or when installing it on a widget-less page.

    So the error seems to be related to widgets, rather than specifically the Random Content Widget.

    Anyone have any clues on why Widgets might not be saving their state?

    Thanks

    Richard

  • RichardMortimer
    Avatar
    Community Member
    15 Posts

    Re: RandomContentWidget not saving state Link to this post

    *bump*

    Anyone??

  • Pigeon
    Avatar
    Community Member
    243 Posts

    Re: RandomContentWidget not saving state Link to this post

    Hmm, i think i had this problem too.

    I would drag a widget over to add it to a page, save & publish and on reloading the admin area it was gone (not saved). It was definitely a problem with my code that i fixed, i just cant remember what. Keep debugging, start again or post complete code.

    1331 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.