Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Hosting Requirements /

What you need to consider when choosing a hosting provider and plan.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Quick question: LiteSpeed web server


Go to End


2 Posts   427 Views

Avatar
neilcreagh

Community Member, 136 Posts

31 July 2017 at 2:06am

Just a quick question to ask if there's any known issues running Silverstripe on a LiteSpeed Web Server?
From what I understand it should be the same as Apache.

I've just installed and received an open_basedir restriction warning (below) - it's shared hosting and I don't have direct access to change a php.ini file - where should I put a php.ini file in order to change this - in the root or in the framework folder?

[Warning] is_readable(): open_basedir restriction in effect. File(/usr/bin/pear/Zend/Translate/Adapter/I18nRailsYamlAdapter.php) is not within the allowed path(s) 

Thanks

Avatar
neilcreagh

Community Member, 136 Posts

31 July 2017 at 11:11pm

Update: This fixed my issue - and everything else since seems to be working well on LiteSpeed
https://www.silverstripe.org/community/forums/installing-silverstripe/show/20224?start=16