Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Upgrading from userform 0.1 to 0.2.0 problems

Go to End

4 Posts   1380 Views


Community Member, 16 Posts

8 January 2010 at 5:53am

Edited: 08/01/2010 6:13am


We have tried to upgrade from userform 0.1 to 0.2.0, but get an Error when we try to add a UserDefinedForm in the cms. ("there has been an error"). We use Silverstripe 2.3.4 and experienced that the userform not was working properly after upgrading to 2.3.4. When a user sends a form he dont get the comfirmationpage.

We have noticed that the Url to the confirmationpage doesnt show up. It should like this: . But on the 2.3.4 CMS with 0.1 userform the url shows only:

Thats why we would install userform 0.2.0.

We deleted the old userform, runed dev/build, then installed the 0.2.0 version and builded the database again. We also tried to delete all the UserDefinedFOrm and submitted form tables in the database.

We have noticed in userforms _config is a requirement to FieldEditor.js, while in javscript folder is only Userform.js (but this does not seem to cause a failure on new installations of the module ????) We have also tried to change the requirement call to Userform.js but it makes no difference.

Pleas help!!



Forum Moderator, 5523 Posts

8 January 2010 at 1:28pm

Put the site into devmode to see the actual error in the CMS. To put the site into devmode set Director::set_environment_type("dev"); in your _config and then using the console panel in firefox you should see the actual error message.

If you had existing forms with 0.1 then you can also run the migration script at

Also if you're upgrading you should be using 0.2.1 rather then 0.2.0 -


Community Member, 3 Posts

19 January 2010 at 12:06am

Hi Willr,

I also would like to upgrade from 0.1 to 0.2.1 but I already got some forms and the "" url doesn't work.

How can I migrate my old forms ?
Is there any risk to loose submissions ?

Thank you




Forum Moderator, 5523 Posts

19 January 2010 at 9:36am

Hey Mysth-R.

Could you expand on "it doesn't work". Do you get an error page? something missing?. To run the tasks you may need to have PHPUnit installed and either be in devmode or provide a password.