Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

userforms - Field not obeying custom rules


Go to End


1526 Views

Avatar
theoldlr

Community Member, 103 Posts

7 January 2010 at 5:18pm

What types of fluids are you interested in?
OPTIONS: Cleaners & RP's, Coolants

Any chlorinated paraffins being used? (Radio Button)
OPTIONS: Yes, No
Rules:
-Hide by Default
-Show this field when [What types of fluids are you interested in?] is [Value] [Cleaners & RP's]

How much? (Dropdown Field)
RULES
-Hide by Default
-Show this field when [Any chlorinated paraffins being used? ] is [Value] [Yes]
-Hide this field when [What type of fluids are you interested in?] is [Value] [Coolants]

I've tried changing the [How much?] field rules around. It is always hidden by default (good!), but when the [Any chlorinated paraffins being used?] field becomes visible (from the user changing the value of the [What types of fluids are you interested in?] field to [Cleaners & RP's]) the [How much?] field also becomes visible despite the fact that the [Any chlorinated paraffins being used?] has neither radio button selected yet. I also tried deleting and recreating the [How much?] field, deleting, recreating and changing the order of the values on the [Any chlorinated paraffins being used?]

What am I missing??