Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

SS 2.3.5 breaks translatable?

Go to End

3 Posts   1071 Views


Community Member, 103 Posts

3 February 2010 at 10:08am

Hi all,

I have a site setup with translations on SS 2.3.3 that is working as it should. I used the exact same code from mysite/_config.php for a new 2.3.5 and now it is not working. In the CMS the language dropdown is present with the default language only. When on the translations tab of a Page the New Translation Dropdown is empty. Here is the portion of code from _config.php regarding translatable:

Object::add_extension('SiteTree', 'Translatable');

//global $allowed_locales;
$allowed_locales = array(




Community Member, 323 Posts

3 February 2010 at 12:08pm


In my setup, which is working, I don’t use Translatable::set_allowed_locales($allowed_locales); but i18n::$common_locales = $allowed_locales;. I know that it doesn’t mean the same thing, but maybe it can help.

You should look in CMS code where the list New Translation is coming from, there’s maybe a bug somewhere.



Community Member, 103 Posts

5 February 2010 at 2:18am

Thanks Juan!

Your method worked... though I cannot explain why my previous method worked before and not now.

For anyone else that might be having the same problem here is the code that is working for me on SS 2.3.5:

Object::add_extension('SiteTree', 'Translatable');

$allowed_locales = array(
 'en_US' => array('English', 'English'),
 'pt_BR' => array('Portuguese', 'Português'),
 'es_CL' => array('Spanish', 'Español')

i18n::$common_locales = $allowed_locales;